
Adobe Flash Professional Guide
How to create animations

Overview of tweening

A tween is an animation you create by specifying a value for an object property in one frame and another value for 
that same property in another frame. Adobe Flash Professional calculates the values for that property between those 
two frames. The term “tween” comes from the phrase “in between.” You can tween movie clip, graphic, and button 
symbols and text fields.

A tween span is a group of frames in the timeline in which an object on the Stage can have one or more properties 
changed over time. A tween span appears in the timeline as a group of frames in a single layer with a blue or green 
background. You can select a tween span as a single object and drag it from one location in the timeline to another, 
including to another layer. Only one object on the Stage can be animated in each tween span. This object is called the 
target object of the tween span.

A property keyframe is a frame within a tween span where you explicitly define one or more property values for the 
tween target object. Each property you define has its own property keyframes. If you set more than one property in a 
single frame, the property keyframes for each of those properties reside in that frame. You can view each property of 
a tween span and its property keyframes in the Motion Editor. You can also choose which types of property 
keyframes to display in the timeline from the tween span context menu.

Beginning with Adobe Flash Professional CS4, the concepts of keyframe and property keyframe differ from earlier 
versions of Flash. The term keyframe refers to a frame in the timeline in which a change occurs, such as a symbol 
instance appearing on the Stage for the first time. The term property keyframe, new to Flash CS4, refers to a value 
defined for a property at a specific time or frame in a motion tween.

Types of Flash Animation

Motion tweens: Set properties for an object, such as position and alpha transparency in one frame and again in another 
frame, and Flash interpolates the property values of the frames in between. Motion tweens are useful for animation 
that consists of continuous motion or transformation of an object. Motion tweens appear in the timeline as a 
contiguous span of frames you can select as a single object by default. Motion tweens are powerful and simple to 
create.

Shape tweens: Draw a shape at one frame in the timeline and change that shape or draw another shape at another 
frame. Flash then interpolates the intermediate shapes for the frames in between, creating the animation of one shape 
morphing into another.

Classic tweens: Classic tweens are similar to motion and shape tweens, but you can create some specific animated 
effects not possible with span-based tweens. For example, you can apply eases to the groups of frames between the 
keyframes within the tween instead of across the entire length of a tween span. (To ease only specific frames of a 
motion tween, you must create a custom ease curve.) You can also use classic tweens to animate between two color 
effects, such as tint and alpha transparency, while motion tweens can apply only one color effect per tween.

Inverse kinematic (IK) poses: You can stretch and bend shape objects and link groups of symbol instances to make 
them move together in naturalistic ways. If you position the shape object or linked instances in different ways in 
separate frames, Flash interpolates the positions in the frames in between. Inverse kinematics poses help make 
character animation quick and easy.

Note: You will learn more about how to use inverse kinematic poses in the “How to create character animations” 
guide.

Motion tweens

You apply motion tweens only to symbol instances and text. All other objects must be converted to symbols before 
you can animate them by using a motion tween. 
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A motion tween begins with a target symbol instance in the first keyframe of the tween span. You create motion by 
adding a property keyframe somewhere later in the timeline and changing the symbol properties, such as position, 
scale, or rotation. You can edit the individual properties of each symbol instance by using the Properties panel or the 
Motion Editor. You can also drag a symbol instance to a new location on the Stage or manipulate it by using the Free 
Transform tool. 

Note: A tween span can have only one target object. If you add a second symbol to a tween span, the new symbol 
replaces the original one. That means you can deliberately replace the target object of a tween by dragging a different 
symbol from the library onto the tween span in the timeline. 

To create a motion tween:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Draw a shape on the Stage.

The shape appears in keyframe 1 of Layer 1.

3. Using the Selection tool (Figure 1), double-click to 
select the shape fill and stroke, if present. 

4. Choose Modify > Convert To Symbol. 

The Convert To Symbol dialog box appears (Figure 2).

Note: Applying a motion tween to a shape automatically 
converts the shape to a symbol.

5. Type a new name for the symbol in the Name text box, 
select Graphic for Type, and click OK (Figure 2).

6. Select frame 10.

7. Select Insert > Timeline > Frame. (The motion tween will 
last for 10 frames.)

When you insert a frame, Flash fills the area between the 
last frame (on the current layer) and the new frame with 
the same content (Figure 3). Frames 1 through 10 all 
contain the new symbol.

8. Make sure frame 10 (the end frame for the motion tween) 
is selected and select Insert > Motion Tween.

9. With frame 10 still selected in the timeline, select the 
symbol on the Stage (with a single click). Make one or 
more of the following changes:

Color change: In the Properties panel, select Tint from 
the Color Effect Style menu. Select 100% for the Tint 
Amount and change the color in the Tint Color box 
(Figure 4).

Fading: In the Properties panel, select Alpha from the 
Color Effect Style menu. Reduce the percentage of the 
Alpha Amount for more transparency. For example, an 
Alpha value of 0% makes the object disappear.

Position: Use the Selection tool to move the object to a 
different position on the Stage. A motion path appears. 
The points on this motion path are editable.

Figure 1 Tools panel

Figure 2 Convert To Symbol dialog box

Figure 3 Inserted frame

Figure 4 Properties panel

Selection tool
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Size: Select the object. Then select Modify > Transform > 
Free Transform. Drag the object handles to increase size, 
decrease size, or rotate the object.

10. Click away from the symbol on the Stage to deselect it 
and select frame 1 in the timeline. 

In the timeline, the motion tween is represented by a solid 
blue background running from the start keyframe to the 
end keyframe (Figure 5). When you changed the 
properties of the symbol in frame 10, frame 10 was 
automatically converted to a property keyframe.

With the target object selected in frame 1, the tween’s 
properties appear in the Properties panel (Figure 6).

11. Adjust one or more properties of the motion tween in the 
Properties panel.

• Ease: Controls how fast the object starts or ends the 
motion tween. For example, a high number makes an 
object begin tweening quickly and end slowly.

• Rotate: Rotates the object clockwise or 
counterclockwise a designated number of times.

• Path: If you add a guide layer, the object is linked to 
the path drawn on the guide layer.

• Sync Graphic Symbols option: Starts and stops the 
tweening of all objects on the Stage at the same time.

12. Select the Motion Editor panel (Figure 7).

You can view and adjust all tween properties and 
property keyframes in the Motion Editor. 

• You can add or remove property keyframes for 
individual properties.

• You can move property keyframes to different 
frames within the tween.

• You can add or remove filters or color effects and 
adjust their settings.

• You can add different preset eases to individual 
properties and property categories.

• You can create custom ease curves.

• You can enable roving for individual property 
keyframes for X, Y, and Z properties. Roving allows 
the property keyframe to move to different frames or 
between individual frames to create smooth motion.

Figure 5 Motion tween in the timeline

Figure 6 Motion tween properties

Figure 7 Motion Editor panel
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13. Select Control > Test Movie > In Flash Professional to 
test the movie.

14. Select File > Close to close the preview window.

15. Select the Timeline panel.

16. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel 
(Figure 8).

17. Drag the onion skinning frame handles (they appear as 
brackets with circles on them at the top of the timeline) to 
span the frames in which the object appears.

All the intermediate steps of the tween are visible on the 
Stage (Figure 9).

18. Turn off onion skinning by clicking the Onion Skin 
button again.

19. Save the movie.

Figure 8 Onion Skin button (shown selected)

Figure 9 Onion skinning visible

Shape tweens

In shape tweening, you draw a vector shape at one specific frame in the timeline and change that shape or draw 
another shape at another specific frame. Flash then interpolates the intermediate shapes for the frames in between, 
creating the animation of one shape morphing into another.

Note: Shape tweens work best with simple shapes. Avoid shapes with cutouts or negative spaces in them. Experiment 
with the shapes you want to use to determine the results. You can use shape hints to tell Flash which points on the 
beginning shape should correspond to specific points on the end shape. Shape tweens can use much more computer 
memory than motion tweens, so it is best to use shape tweens sparingly.

Onion Skin button
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To create a shape tween:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

Frame 1 in Layer 1 already contains a blank keyframe.

2. Begin by adding a shape to the Stage:

Drawn objects: Select a shape tool (Rectangle, Oval, or 
PolyStar) and draw a shape on the Stage.

Text: Select the Text tool and type a word or phrase on 
the Stage. Then select the text and select Modify > Break 
Apart. This breaks the words into separate letters. With 
the letters still selected, select Modify > Break Apart 
again to convert the letters into shapes.

Outside images: Select File > Import > Import To Stage 
to import an image. If the image is a bitmap, you must 
break it apart. If the image is a grouped vector drawing, 
you must ungroup it completely. To break apart a bitmap, 
select Modify > Break Apart. To ungroup an image, 
select Modify > Ungroup.

Note: You might need to select Modify > Break Apart or 
Modify > Ungroup multiple times until the object 
becomes a shape, as indicated in the Properties panel.

3. Using the Selection too, select frame 10.

4. Select Insert > Timeline > Keyframe.

The tween will last for 10 frames.

5. Make sure frame 10 is still selected and make one or 
more of the following changes to your shape:

Amorphous shape change: Click the Stage with the 
Selection tool to deselect the object. Bring the Selection 
tool close to the object to grab an edge (Figure 10). Drag 
the edge to modify the shape (Figure 11). The result is an 
amorphous shape change (Figure 12).

Different shape: To morph between your original shape 
and a new object, delete the object in keyframe 10 and 
draw a new object.

Note: Select Modify > Break Apart if the drawn object is 
not a shape.

Text: To morph between your original shape and some 
text, delete the object in keyframe 10 and type the text on 
the Stage. Select Modify > Break Apart until the text 
block is a shape, as indicated in the Properties panel.

Outside image: To morph between your original shape 
and a new image you import, delete the object in 
keyframe 10 and select File > Import to bring in the 
outside image. Select Modify > Break Apart to make the 
object a shape, as indicated in the Properties panel.

Figure 10 Select an edge of the shape

Figure 11 Drag to modify the shape

Figure 12 Amorphous shape change
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6. Click anywhere inside the tween span on the timeline and 
select Insert > Shape Tween.

Green shading with an arrow between keyframes 
indicates a shape tween span (Figure 13).

7. Select frame 1 on the timeline (on the current layer).

This is the start frame for the animation.

8. In the Tweening section of the Properties panel, adjust 
one or more properties of the Shape tween (Figure 14):

Ease: Controls how fast the object starts or ends the 
shape tween. For example, a high number begins the 
tweening quickly and ends slowly.

Blend (Distributive): Creates an animation in which the 
intermediate shapes are smoother and more irregular.

Blend (Angular): Creates an animation that preserves 
corners and straight lines in the intermediate shapes.

9. Select Control > Test Movie > In Flash Professional to 
test the movie.

10. Close the preview window.

11. To see all phases of the tween at the same time, click the 
Onion Skin button at the bottom of the Timeline panel.

12. Drag the frame handles (they appear as brackets with 
circles on them at the top of the timeline) to span the first 
10 frames of Layer 1.

The steps of the tween are all visible on the Stage.

13. Turn off onion skinning by clicking the Onion Skin 
button again.

Figure 13 Shape tween span

Figure 14 Properties panel

Classic tweens

In classic tween animation, you define keyframes at points in the animation and Flash creates the contents of the 
frames in between. The interpolated frames of a classic tween animation appear as light blue shading with an arrow 
drawn between keyframes. Because Flash documents save the shapes in each keyframe, create keyframes only at 
those points in the artwork where something changes.

You can create certain types of animated effects by using classic tweens that not possible with motion tweens.

• Add animation to symbol instances, object groups, or text

• Add timeline effects

• Paste motion tween properties

• Apply custom ease-in/ease-out settings

Note: Advanced uses of classic tweens, such as those listed here, will be dealt with in greater detail in Project 6. The 
following exercise outlines the steps for creating a simple classic tween, which serves as a basic introduction to 
classic tweening and the procedural differences between classic and motion tweening.
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To create a classic tween:

1. Start Flash and open a blank document 
(ActionScript 3.0). 

Frame 1 in Layer 1 already contains a blank keyframe.

2. Begin by adding a symbol to the Stage.

Note: You may need to add a shape, image, or text first 
and convert the object to a new symbol.

3. Select frame 10.

4. Select Insert > Timeline > Keyframe.

The tween will last for 10 frames (Figure 15).

5. Make sure frame 10 is still selected and move the symbol 
to a new position on the Stage.

6. Click between frames 1 and 10 in the timeline and select 
Insert > Classic Tween. 

The classic tween appears as light blue with an arrow 
(Figure 16).

7. Select frame 1 on the timeline (on the current layer).

This is the start frame for the animation.

8. Adjust the position, color, or scale of the symbol in the 
starting keyframe.

9. Select frame 10, and adjust the position, color, or scale of 
the symbol to be as you want the animation to end.

10. Select Control > Test Movie > In Flash Professional to 
test the movie.

11. Close the preview window.

Figure 15 Start and end keyframes

Figure 16 Classic tween span
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