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How to create a button symbol

Button symbols

Buttons give visitors a way to control parts of a movie. You can use button symbols to create interactive buttons that
respond to mouse clicks, rollovers, or other visitor interaction. Button symbols are four-frame interactive movie clips.
The first three frames display the button’s three possible states: Up, Over, and Down. The fourth frame, Hit, defines
the active area of the button. The timeline for a button doesn’t play like other movies; it reacts to pointer movement
and actions by jumping to and displaying the appropriate frame.

You can create the image that represents your buttons in several ways. For example, you can use an existing graphic
as the button, or you can create a shape by using the drawing tools.

Create a button

You will create a new button symbol that contains two layers. One layer will contain a shape representing the
background of the button. The second layer will include a text label for the button. You will change the background
and text label in the Over and Down states of the button to create the rollover effect.

To create a button:

1. Start Flash and open a new blank document e %
(ActionScript 3.0). d ht
2. Select Insert > New Symbol. Neme: [Z= |

The Create New Symbol dialog box appears (Figure 1).

Folder: Library root

[ ok |
Type: | Button | =

3. Select Button for Type, name the button, and click OK. el
You are now in symbol-editing mode and viewing a L =
separate timeline for the button symbol. The Up frame Figure 1 Create New Symbol dialog box
contains a keyframe (Figure 2).
Each frame on the timeline of a button symbol has a Timeline | Output | Motion Editor |
specific function: = @ [ Up |Over Down Hit
uJ Z O . |

»  Up state: Represents the button’s appearance ]
whenever the pointer is not over the button.

»  Over state: Represents the button’s appearance when

. . ) al o RN NS
the pointer is over it.

Figure 2 Button frames: Up, Over, Down, Hit

» Down state: Represents the button’s appearance as it
is clicked.

» Hit state: Defines the area that will respond to a
mouse click. This area will be invisible in the
published movie.

4. Make sure the Up frame is selected.

5. Use the drawing tools to create a shape for your button.
Use the Properties panel to set the fill and stroke colors
for the Up state of the button.

6. Select the Over state and select Insert > Timeline >
Keyframe to add a keyframe.

Adding this keyframe copies the button graphic from the
Up frame to the Over frame.
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10.
11.

12.
13.

14.

15.
16.

17.

18.

19.

20.

21.

22.

Select the Over keyframe and use the Selection tool to
select the button.

Change the fill or stroke color of the button shape.

When visitors roll over the button, the button will appear
as you see it in the Over frame.

Insert keyframes in the Down and Hit frames of the layer.

This copies the button graphic from the Over frame to the
Down and Hit frames.

Insert a new layer and name it Text.

Select the Up frame of the Text layer.

This frame already contains a keyframe.

Use the Text tool to type text on the button shape.

Use the Properties panel to adjust the font, size, and color
of the text so it fits nicely on your button shape.

Use the Selection tool or the Up, Down, Left, and Right
Arrow keys to position the text on the button shape.

Insert a keyframe in the Over frame of the Text layer.

Select the text and use the Properties panel to change
some feature of the text in the Over frame, such as color.

Insert a keyframe in the Down frame. If you want the text
to change appearance when the button is clicked, edit the
appearance of the text in the Down frame.

The timeline should now appear as it does in the example
(Figure 3).

Now you can insert an instance (copy) of the button
symbol into the main timeline of your movie.

Click Scene 1 (Figure 4) to exit symbol-editing mode
and return to the main timeline.

Select Window > Library to display the Library panel.

The new button symbol appears in the Library panel
(Figure 5).

Note: You must select the symbol in the library to see the
symbol in the preview pane.

Drag the button symbol from the Library panel onto the
Stage.

Select Control > Test Movie > In Flash Professional to
test the movie.

When you roll over the button with the pointer, you see
the changes you defined in the Over frames for the
button. If you edited the Down state of the button, this
will be visible when you click the button.

Close the preview window.
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Figure 3 Button timeline
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Figure 4 Symbol-editing mode
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Figure 5 Library panel, with the button selected
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Adding sound to a button

You can also add sounds to a button so visitors hear a sound when they interact with the button.

To add sound to a button:

1.

10.

Continue from where you left off in the preceding
activity.

Use the Selection tool to double-click the button.
You enter symbol-editing mode for the button.
Insert a new layer and name it Sound.

Select File > Import > Import To Library to import a
short sound into the library.

You can acquire royalty-free sounds from sites such as
www.flashkit.com.

On the Sound layer, add a keyframe to correspond with
the button state to which you want to add a sound.

For example, to play a sound when visitors roll over the
button, add the keyframe to the Over state.

Click the new keyframe.

In the Sound section of the Properties panel, select a
sound file in the Name menu (Figure 6).

The sound waveform appears in the Sound layer in the
Timeline panel (Figure 7).

Select Event in the Sync menu (Figure 6).

The sound will play when visitors interact with the
button.

Select Control > Test Movie > In Flash Professional to
test the movie.

When you interact with the button, you hear the sound.

Close the preview window.

© 2012 Adobe Systems Incorporated
This document requires Adobe Flash Professional CS6. Technical instructions may differ depending on your version.

Properties | Library | =
’—r Frame @
l
= LABEL
Name: |
Type: | Name v
— SOUND
Name: | ding_dong.wav , | ]
Effect: | None \\ |v] &
sync: | Event / \\‘ | v
| Repeat/ [ v} x 1

22 kHz/Mono 16 Bit 2.9 5 \128.4 kB

Sync menu Name menu

Figure 6 Properties panel, sound properties
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Figure 7 Timeline panel
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Adding control with actions

Right now the button looks great, but it doesn’t perform any action. You can remedy this by adding ActionScript
code to your movie. The ActionScript code contains the instructions for what do when someone interacts with the
button. Buttons give visitors control over the movie. You can use a button to stop the movie, start and stop sounds,
restart the movie (after stopping it), or jump to different frames within the movie and continue playing.

The ActionScript code references a button’s instance on the Stage, not the symbol stored in the library. This lets you
use the same button symbol to perform different actions, depending on where it appears in your movie.

To add control with actions:

1.

10.

11.

12.

Continue from where you left off in the preceding
activity.

Select the button instance to which you want to add an
action.

Click in the Instance Name box in the Properties panel
(Figure 8) and enter a unique name to identify the button
instance. The name should be descriptive, such as
sound_btn, and cannot contain spaces.

In the main timeline of your movie, create a new layer
named Actions.

Make sure there is a keyframe in the Actions layer that
corresponds to the keyframe where your button first
appears on the Stage. Select this keyframe in the Actions
layer.

Note: If your button doesn’t appear on this frame, Flash

generates an error message when you publish the movie

because the ActionScript you include on this frame refers
to an object that isn’t on the Stage yet.

Select Window > Actions to display the Actions panel.

If you don’t see the parameters area in the Actions panel,
click the Script Assist button.

In the Actions toolbox on the left side of the panel, select
the AddEventListener method for the IEventDispatcher
class.

To find the AddEventListener method, expand
Flash.Events, and then expand IEventDispatcher and then
Methods.

Double-click the AddEventListener method to add it to
the Script pane (Figure 9).

Click in the Object box in the parameters area of the
Actions panel.

The Insert Target Path button is now active.
Click the Insert Target Path button.
The Insert Target Path dialog box appears (Figure 10).

Select the Relative option and select the instance name of
your button. Click OK to close the dialog box.

How to create a button symbol
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Figure 8 Properties panel
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3

Figure 9 AddEventListener method
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Figure 10 Insert Target Path dialog box
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13. Inthe Actions toolbox on the left side of the panel, select S

the CLICK property from the MouseEvent class. o ST

To find the CLICK property, expand Flash.Events, and 7 el ol < Wil

. [priority]: <int: [useMieak Reference] Boolza

then expand MouseEvent and then Properties. P 9 cotosovers [ @
14. In the Script pane, select the AddEventListener() lineto | S e I

display the parameters for this method. Then, in the

parameters area, click in the Type box.

15. In the Actions toolbox, double-click the CLICK property.

Script Assist adds the property to your code as
MouseEvent.CLICK (Figure 11).

16. In the Listener box in the parameters area, type a name
for the function that should execute when the button is
clicked. You can use any name you like, but make sure
the name of the function is unique and contains no
spaces.

The function name appears in the Script pane as you type.
You have named the function, but you haven’t created it
yet.

17. Inthe Actions toolbox, select the function keyword from
Language Elements.

To find the function keyword, expand Language
Elements. Then expand Statements, Keywords &
Directives, and expand Definition Keyword.

18. Double-click the function keyword in the Actions
toolbox.

The code for creating a function appears in the Script
pane.

19. In the parameters area of the Script pane, type the name
of your function in the Name box.

Note: You must type the function name exactly as you
typed it for the AddEventListener function. Function
names are case-sensitive.

20. In the parameters area of the Script pane, type
event:MouseEvent in the Parameters box (Figure 12).

In this box, you are naming a variable (event) and
indicating what type of variable it is (MouseEvent).

21. Inthe Actions toolbox on the left side of the panel, select
the StopAll method for the SoundMixer class.

To find the StopAll method, expand Flash.Media, expand
Methods, and then expand SoundMixer.

© 2012 Adobe Systems Incorporated

Figure 11 CLICK property in the Script pane

function : Comprises 3 set of statements that you define to perform a certain task.
MName:  turnOffSound

Parameters: event:MouseEvent

Type: <Type ~  [/] Add Impart Action for Type

#F code Snippets g

Figure 12 Function code in the Script pane
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22. Select the function in the Script pane and double-click 4=p5 3 o>

#5 Code Snippets S @
the StopAll method in the Actions toolbox. | e e e i
£} Object (this) . Sﬂd'ldihnn. addEventListener (MouseEvent.CLICK, turnCffSound) ;
The method is added to the function (Figure 13). | ey

a0 n

23. Now when visitors click the button, all sounds currently
playing in the movie will stop. Figure 13 StopAll method in the Actions panel

For more about ActionScript, see Programming ActionScript 3.0, “Getting Started with ActionScript” (in Flash,

select Help > Flash Help. Select ActionScript 3.0 And Components, select Programming ActionScript 3.0, and select
Getting Started With ActionScript).
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