
Adobe Flash Professional Guide
How to create transitions with motion tweens
You may have noticed from watching television or movies that transitions are a subtle but important part of telling a 
story. For example, dissolving between images can indicate a passage of time. On the web, you can use transition 
effects to create moods and to help keep your visitors interested. You can use transitions to focus the visitor’s 
attention or to indicate a preferred path through your site. One way to create transitions in Adobe Flash Professional 
is to apply effects to a motion tween.

Rotation

In the Properties panel, you can add rotation to any motion tween. Rotation can draw attention to content that is 
entering or exiting the Stage.

To add rotation to a motion tween:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Use the drawing tools to create a shape and convert the 
shape to a graphic or movie clip symbol. Make sure the 
Object Drawing option is not selected in the Tools panel. 
Make sure the new symbol is alone on its own layer. 

By default the symbol is placed in the first keyframe of 
the timeline (Figure 1). 

3. Insert a frame (not a keyframe) in the timeline where you 
want the motion tween to end (Figure 2).

Note: To make the effect last longer (take longer to 
complete) place the end frame farther down the timeline. 
You can use the Frames Per Second (fps) and Elapsed 
Time (s) values in the Timeline panel determine where to 
place the end keyframe.

4. Select the layer in the Timeline panel and select Insert > 
Motion Tween.

The motion tween span is light blue in the Timeline 
panel.

5. Select the last frame in the motion tween span and use the 
Selection tool to move the object to its ending position. 
Notice the appearance of the motion path (Figure 3).

Note: You can add multiple effects, such as changing 
size or fading to make the object appear to grow or fade 
in while it enters or fade out and shrink as it exits.

• Changing size: Reduce or increase the image 
percentage in the Transform panel with the 
Constrain options selected.

• Fading: Select the symbol and select Alpha from the 
Style menu in the Color Effect section of the 
Properties panel. Adjust the alpha setting to increase 
or decrease transparency.

Figure 1 Timeline panel

Figure 2 Motion tween start and end frames

Figure 3 Motion path
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6. Click anywhere in the motion tween span in the Timeline 
panel.

The motion tween properties appear in the Properties 
panel (Figure 4).

7. In the Rotation section of the Properties panel, select CW 
(clockwise) or CCW (counterclockwise) from the 
Direction menu (Figure 5).

8. Change the Rotate value to set the number of times you 
want the symbol to rotate (Figure 6).

9. In the Options section, select the Sync Graphic Symbols 
option (Figure 7).

This synchronizes the motion to the number of frames in 
the timeline.

10. Select Control > Test Movie > In Flash Professional to 
test the movie.

11. Close the preview window.

Figure 4 Motion tween properties

Figure 5 Direction menu in the Properties panel

Figure 6 Rotate value in the Properties panel

Figure 7 Synchronize the rotation to the timeline
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Change frame rate

The document’s frame rate determines how fast the play head moves. A frame rate of 12 frames per second (fps) 
usually gives the best results on the web. You can set the frame rate to any number between 0.01 and 120. With larger 
movies, increasing the frame rate increases the size of your published document.

If you want to change the timing of an animation, it’s usually better to change the number of frames than to change 
the frame rate.

To change the frame rate:

1. Click away from any objects on the Stage.

Document properties are shown in the Properties panel.

2. Enter a new Frames Per Second (FPS) value, such as 30,  
in the Properties section of the Properties panel 
(Figure 8).

3. Select Control > Test Movie > In Flash Professional to 
test the movie.

Observe that the animation plays faster or slower 
depending on the frame rate you set.

4. Close the preview window.

5. Change the FPS value to 6.

6. Select Control > Test Movie > In Flash Professional to 
test the movie.

Observe that the animation plays much more slowly.

7. Close the preview window.

Figure 8 Properties panel
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Fading

By creating a motion tween with different alpha settings, you can fade images in and out.

To fade images in and out:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Use the drawing tools to create a shape and convert the 
shape to a graphic or movie clip symbol. Make sure the 
new symbol is alone on its own layer. 

By default the symbol is placed in the first keyframe of 
the timeline. 

3. Insert a frame (not a keyframe) in the timeline where you 
want the fade to end.

Note: To make the effect last longer (take longer to 
complete) place the end frame farther down the timeline. 
You can use the Frames Per Second (fps) and Elapsed 
Time (s) values in the Timeline panel determine where to 
place the end keyframe.

4. Select the layer in the Timeline panel and select Insert > 
Motion Tween.

5. In the timeline, select the first frame in the motion tween 
span and click the symbol on the Stage.

6. In the Properties panel, open the Color Effect Style menu 
and choose Alpha (Figure 9).

The Alpha value changes to the last Alpha setting you 
applied. The default is 0% (transparent) (Figure 10).

7. Make sure the Alpha value is set to 0%.

The symbol on the Stage is transparent, but the blue 
outline of the symbol is still visible.

8. In the timeline, select the last frame in the motion tween 
span and click the symbol on the Stage.

9. Change the Alpha value to 100%.

10. Select Control > Test Movie > In Flash Professional to 
test the movie.

The symbol fades in.

Note: To create a fade-out, set the Alpha value to 100% 
on the starting frame and the Alpha value on the ending 
frame to 0%.

11. Close the preview window.

Figure 9 Properties panel, Color Effect Style menu 

Figure 10 Alpha value slider
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Color fades

You can use color fades to draw the viewer’s attention to an object on-screen. To create a color fade, apply a motion 
tween between two instances of the same movie clip or button symbol, and then change the color of the instances in 
the starting and ending frames.

To create a color fade:

1. Start Flash and open a new blank document 
(ActionScript 3.0).

2. Use the drawing tools to create a shape and convert the 
shape to a movie clip or button symbol. Make sure the 
new symbol is alone on its own layer. 

Note: It’s important that you make the object a movie 
clip or button symbol. You will use a filter to adjust the 
color and you cannot add filters to graphic symbols.

By default the symbol is placed in the first keyframe of 
the timeline. 

3. Insert a frame (not a keyframe) in the timeline where you 
want the color fade to end.

4. Select the layer in the Timeline panel and select Insert > 
Motion Tween.

5. In the timeline, select the last frame in the motion tween 
span and click the symbol on the Stage.

6. In Properties panel, click the Add Filter button and 
choose Adjust Color in the Add Filter menu (Figure 11).

7. In the Filters section of the Properties panel, use the Hue 
scrubber to change the color of the symbol (Figure 12).

As you change the value, notice the changing color of the 
symbol on the Stage.

8. Select Control > Test Movie > In Flash Professional to 
test the movie.

9. Close the preview window.

Figure 11 Properties panel, Add Filter menu

Figure 12 Hue scrubber in the Properties panel

Add Filter button
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Flipping images

Flipping images and then creating a motion tween can create an effective transition between images of roughly the 
same size. The trick is to flip the first image half way and then start fading in the second image while the first image 
is still flipping to make a smooth transition.

To flip an image:

1. Start Flash and open a new blank document 
(ActionScript 3.0). 

2. Import or create the objects you want to flip between.

3. Convert both objects to movie clip symbols and then 
remove them from the Stage. The symbols will remain in 
the document library.

Note: In this example, we imported two photos of similar 
size to the Stage, converted them to symbols, and then 
removed them from the Stage.

4. In the Timeline panel, rename Layer 1 exiting object. 
Add a new layer and rename it entering object 
(Figure 13).

5. Add the image symbols from the document library to the 
blank keyframes in each layer. One image is the entering 
object and the other is the exiting object.

6. Decide how much time is required to complete the 
transition. 

This tells you where to place the ending frames for each 
of the images for the motion tweens.

7. Insert the ending frames (not keyframes) accordingly in 
the timeline (Figure 14). 

8. For each image, select the layer in the timeline and 
choose Insert > Motion Tween.

9. Click the first frame in the top, entering object, layer. 
Select the image and change its Color Effect (in the 
Properties panel) to Alpha with an Alpha value of 0%.

10. Click the last frame in the top, entering object, layer. 
Select the image and set the Alpha Amount to 100%.

The entering image is transparent in the beginning and 
becomes visible.

11. Lock the top, entering object, layer by clicking in the 
Lock Layer column (Figure 14).

Locking the top layer makes it easier to work with the 
image in the layer below it.

Figure 13 Entering and exiting layers in the 
timeline

Figure 14 Start and end frames for the tween

Lock Layer column
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12. Click the first frame in the bottom, exiting object, layer. 
Select the image and change the Color Effect to Alpha 
with an Alpha value of 100%. 

13. Click the last frame in the bottom, exiting object, layer. 
Select the image and change the Alpha value of 0%. 

The exiting image is visible in the beginning and 
becomes transparent.

14. Click in the center frame of the tween span in the bottom, 
exiting object, layer and select Modify > Transform > 
Flip Horizontal.

The exiting object is flipped around a vertical axis 
through its center. This adds a keyframe in the center of 
the tween span (Figure 15).

15. Lock the bottom layer and unlock the top layer.

16. Click in the center of the tween span in the top, entering 
object, layer and select Modify > Transform > Flip 
Horizontal.

The entering object is flipped around a vertical axis 
through its center. A keyframe appears in the center of 
the top, entering object, tween span (Figure 16).

Note: Instead of Flip Horizontal, you can select Flip 
Vertical in both tween spands. As long as both exiting 
and entering objects flip the same way, the transition will 
work.

17. In the Properties panel, change the Easing value to -100 
(Figure 17).

18. Unlock the bottom layer and select it. In the Properties 
panel, change the Easing value to -100.

Changing the easing value adjusts the rate of change 
between tweened frames. Negative easing values cause 
the motion tween to begin slowly and accelerate at the 
end of the tween. A positive value causes the tween to 
begin rapidly and decelerate at the end. The animation 
still takes the same amount of time, regardless of the 
easing value.

19. Select Control > Test Movie > In Flash Professional to 
test the movie.

20. Close the preview window.

Figure 15 Flip keyframe in the exiting object 
tween span

Figure 16 Flip keyframe in the exiting object 
tween span

Figure 17 Properties panel, Ease value 
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Motion presets

You can also add motion presets to movie clip symbols. Motion presets are pre-configured motion tweens you can 
apply to an object on the Stage. You simply select the motion clip symbol and click the Apply button in the Motion 
Presets panel.

To add a motion preset to your symbol:

1. Start Flash and open a new blank document 
(ActionScript 3.0). 

2. Create a shape and convert it to a movie symbol.

Note: Only movie clip symbols can have motion presets 
applied to them.

3. Display the Motion Presets panel by selecting Window > 
Motion Presets.

You can preview the motion presets by selecting a preset 
from the list of Default Presets (Figure 18).

4. To apply a motion preset to the symbol on the Stage, 
select it and click the Apply button.

5. Click the Motion Editor tab (in the same panel group as 
the Timeline panel) to find the properties for the preset 
you have just applied. Make any changes you like in the 
Motion Editor.

Note: For information on using the Motion Editor, see 
the guide “How to ease tweens.” 

6. After making changes to any motion settings in the 
Motion Editor, save your customized motion preset by 
clicking the Save Selection As Preset button in the lower-
left corner of the Motion Presets panel (Figure 19).

7. Type a name for your custom preset in the Save Preset As 
dialog boxand click OK.

You will now see your motion preset under the Custom 
Presets folder of the Motion Presets panel. You can apply 
your custom motion presets to other tweens in this file or 
new files. Using presets can save significant production 
time during design and development of your projects, 
especially if you often use similar kinds of tweens.

8. Select Control > Test Movie > In Flash Professional to 
test the movie.

9. Close the preview window.

Figure 18 Motion Presets panel

Figure 19 Save Selection As Preset button 
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