
Adobe Illustrator Guide
How to work with text
Type is an important part of Illustrator, and there are many ways to add and manipulate text in your design projects 
(Figure 1). This tutorial presents some basic methods you’ll need to know to add and edit text to your documents.

Figure 1 Using the Touch Type tool

Working with text

Illustrator gives you two ways to apply text to a page: by using point type or by using area type.

Point type is a horizontal or vertical line of text that begins where you click and expands as you enter characters. Each 
line of text is independent—the line expands or shrinks as you edit it but doesn’t wrap to the next line. Entering text 
this way is useful for adding a few words to your artwork.

Area type (also called paragraph type) uses the boundaries of an object to control the flow of characters, either 
horizontally or vertically. When the text reaches a boundary, it automatically wraps to fit inside the defined area. 
Entering text this way is useful when you want to create one or more paragraphs, such as for a brochure.

How to enter text at a point:

1. Select the Type tool or the Vertical Type tool (Figure 2).

The pointer changes to an I-beam within a dotted box. 
The small horizontal line near the bottom of the I-beam 
marks the position of the baseline, on which the text 
rests.

2. Use the Control panel (Figure 3), Character panel, or 
Paragraph panel to set text-formatting options such as 
font, font color, stroke, opacity, style, and size.

3. Click where you want the line of text to begin. 

Note: Be sure not to click an existing object, because 
doing so converts the type object into area type or type on 
a path. If an object exists where you want to enter text, 
lock or hide the object.

4. Enter the text. Press Enter (Windows) or Return (Mac 
OS) to begin a new line of text within the same type 
object.

Figure 2 Tools panel

Figure 3 Setting a font in the Control panel
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5. When you finish entering text, click the Selection tool to 
select the type object (Figure 4). Alternatively, Ctrl-click 
(Windows) or Command-click (Mac OS) the text.

Figure 4 Type object selected

How to enter text in an area:

1. Define the bounding area by doing one of the following:

• Select the Type tool or the Vertical Type tool, and 
drag diagonally to define a rectangular bounding 
area (Figure 5).

• Draw the object you want to use as the bounding 
area. (It doesn’t matter if the object has stroke or fill 
attributes, because Illustrator automatically removes 
them.) Then select the Type tool, the Vertical Type 
tool, the Area Type tool, or the Vertical Area Type 
tool and click anywhere on the object’s path 
(Figure 6). 

Note: If the object is an open path, you must use the 
Area Type tool to define the bounding area. 
Illustrator draws an imaginary line between the 
endpoints of the path to define the boundaries.

2. Use the Control panel (Figure 3), Character panel, or 
Paragraph panel to set text-formatting options such as 
font, font color, stroke, opacity, style, and size.

3. Enter the text. Press Enter (Windows) or Return (Mac 
OS) to begin a new paragraph.

4. When you finish entering text, click the Selection tool to 
select the type object (Figure 7). Alternatively, Ctrl-click 
(Windows) or Command-click (Mac OS) the text.

If you enter more text than can fit within an area, a small 
box containing a plus symbol (+) appears near the bottom 
of the bounding area. 

You can resize the text area or extend the path to display 
the overflow text. You can also thread the text into 
another object.

Figure 5 Creating a type area by dragging

Figure 6 Converting an existing shape to a type 
area

Figure 7 Shape converted to a type area
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About fonts, format, styles, and spacing

In the previous section you applied text to a page by entering text at a point or in an area and then set some basic font 
characteristics. In this section, you will review how to style text in greater detail, including: 

• Setting font family, styles, and size

• Line and character spacing settings such as leading, kern, and tracking

• Alignment, justification, indentation, and paragraph spacing

Fonts

A font is a complete set of characters—letters, numbers, and symbols—that share a common weight, width, and style, 
such as 12-pt Garamond Bold. Typefaces (often called type families or font families) are collections of fonts that 
share an overall appearance and are designed to be used together, such as Garamond (Figure 8). 

Figure 8 Character panel and sample text in Garamond (top) and Garamond Bold (bottom)

A type style is a variant version of an individual font in a font family. Typically, the Roman or Plain (the actual name 
varies from family to family) member of a font family is the base font, which may include type styles such as regular, 
bold, semibold, italic, and bold italic. 

By default, typeface size is measured in points (a point equals 1/72 of an inch). You can specify any typeface size 
from 0.1 to 1296 points, in 0.001-point increments.

How to select a font family and set style and size:

1. Choose Window > Type > Character to open the panel.

2. Select the characters or type objects you want to change. 
If you don’t select any text, the font applies to new text 
you create.

3. Select a font family and style by using the Control panel 
or the Character panel:

• In the Control panel, set the Font and Font Style 
options.

• In the Character panel, set the Font Family and Font 
Style options. In addition to choosing a name from 
the pop-up menus, you can search for specific fonts 
by clicking the current name and typing in the first 
few characters of the name you want (Figure 9). 

Note: You can search fonts by entire font name or by 
first word only by clicking the search fonts 
magnifying glass icon. Figure 9 Character panel

Search fonts
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4. To specify a typeface size, select the characters or type 
objects you want to change.

5. In the Character panel or Control bar set Font Size option 
(Figure 10). 

Figure 10 Selected text and Character panel

Character panel overview

You use the Character panel (Figure 11) to apply options for formatting individual characters in your documents. 
When type is selected or when the Type tool is active, you can also use options in the Control panel to format 
characters (Figure 12). 

Figure 11 Character panel

Figure 12 Control panel

By default, only the most commonly used options are visible in the Character panel. To show all options, choose 
Show Options from the options menu. Alternatively, click the double triangle on the panel’s tab to cycle through the 
display sizes.

Set font size

Font Font style

Font size Leading

TrackingKerning

Font

Font style

Font size

Alignment
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Line and character spacing

You can improve the legibility of a block of text by altering the space between individual lines, adjusting space 
between a pair of characters, or adding or removing space among all letters in a range of text. Changing the space 
between lines of text is called leading. Kerning is the adjustment of space between a pair of characters. Tracking is 
the process of adding or removing space among all letters in a range of text.

Set the leading

The vertical space between lines of type is called leading (rhymes with sledding). Leading is measured from the 
baseline of one line of text to the baseline of the line above it (Figure 13). Baseline is the invisible line on which most 
letters sit.

Figure 13 Default leading for 12-point text (left), and set to 18-point (middle) and 23-point (right)

The default auto-leading option sets the leading at 120% of the typeface size (for example, 14.4-point leading for 12-
point type). When auto-leading is in use, the leading value appears in parentheses in the Leading menu of the 
Character panel. You can change this default auto-leading by choosing Justification from the Paragraph panel menu 
and specifying a percentage from 0 to 500.

By default, leading is a character attribute, which means you can apply more than one leading value within the same 
paragraph. The largest leading value in a line of type determines the leading for that line. 

How to set the leading:

1. Select the characters or type objects you want to change. If you don’t select any text, the leading applies to new 
text you create.

2. In the Character panel, set the Leading option.

Auto-leading
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Kerning and tracking

Kerning is the process of adding or subtracting space between specific pairs of characters. Tracking is the process of 
loosening or tightening the spacing between the characters in selected text or an entire block of text (Figure 14).

Figure 14 Kerning and tracking options: A. Original text; B. Text with optical kerning; C. Text with manual kerning 
between W and a; D. Text with tracking; E. Cumulative kerning and tracking

You can automatically kern type by using metrics kerning or optical kerning. Metrics kerning (also called auto 
kerning) uses kern pairs, which are included with most fonts. Kern pairs contain information about the spacing of 
specific pairs of letters. Some of these are LA, P., To, Try, Ta, Tu, Te, Ty, Wa, WA, We, Wo, Ya, and Yo. Metrics 
kerning is set as the default so specific pairs are automatically kerned when you import or type text.

Some fonts include robust kern-pair specifications. However, when a font includes only minimal built-in kerning or 
none at all, or if you use two different typefaces or sizes in one or more words on a line, you may want to use the 
optical kerning option. Optical kerning adjusts the spacing between adjacent characters based on their shapes. 

You can also use manual kerning, which is ideal for adjusting the space between two letters. Tracking and manual 
kerning are cumulative, so you can first adjust individual pairs of letters and then tighten or loosen a block of text 
without affecting the relative kerning of the letter pairs.

When you click to place the insertion point between two letters, kerning values appear in the Character panel. Metrics 
and optical kerning values (or defined kern pairs) appear in parentheses. Similarly, if you select a word or a range of 
text, the tracking values appear in the Character panel.

Tracking and kerning are both measured in 1/1000 em, a unit of measure that is relative to the current typeface size. 
In a 6-point font, 1 em equals 6 points; in a 10-point font, 1 em equals 10 points. Kerning and tracking are strictly 
proportional to the current typeface size.

How to adjust kerning:

Do any of the following:

• To use a font’s built-in kerning information for selected characters, select Auto or Metrics for the Kerning 
option in the Character panel. 

• To automatically adjust the spacing between selected characters based on their shapes, select Optical for the 
Kerning option in the Character panel (Figure 14). 

Kerning set to optical
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• To adjust kerning manually, place an insertion point between two characters, and set the desired value for the 
Kerning option in the Character panel. (Note that if a range of text is selected, you can’t manually kern the 
text. Instead, use tracking.)

Note: Press Alt+Left/Right Arrow (Windows) or Option+Left/Right Arrow (Mac OS) to decrease or 
increase the kerning between two characters.

• To turn off kerning for selected characters, set the Kerning option in the Character panel to 0 (zero).

How to adjust tracking:

1. Select the range of characters or the type object you want 
to adjust.

2. In the Character panel, set the Tracking option 
(Figure 15).

Figure 15 Selected text and Character panel

Paragraph panel overview

You use the Paragraph panel (Figure 16) to change the formatting of columns and paragraphs. When type is selected 
or when the Type tool is active, you can also use options in the Control panel to format paragraphs (Figure 17).

Figure 16 Paragraph panel

Figure 17 Control panel

Set tracking for selected characters

Alignment buttons

Right indent

Space after paragraph

Left indent

First line indent

Space before paragraph

Justification buttons

Align left Align right

Align center
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By default, only the most commonlyused options in the Paragraph panel are visible. To show all options, choose 
Show Options from the panel menu. Alternatively, click the double triangle on the panel’s tab to cycle through the 
display sizes.

Align and justify text

Text can be aligned left, centered, or right (Figure 18).

Figure 18  Paragraph text aligned left (green), centered (red), and right (blue)

Text is justified when it is aligned with both edges. You can justify all text in a paragraph, either including or 
excluding the last line (Figure 19).

Figure 19  Selected text and Paragraph panel

How to align text:

1. Select the type object or insert the cursor in the paragraph you want to change. 

If you don’t select a type object or insert the cursor in a paragraph, the alignment applies to new text you create.

2. In the Control panel or Paragraph panel, click an alignment button.

How to justify text:

1. Select the type object or insert the cursor in the paragraph you want to justify. 

If you don’t select a type object or insert the cursor in a paragraph, the justification applies to new text you 
create.

2. In the Paragraph panel, click a justification button.

Justify with last line aligned left
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Indent text and paragraph spacing

Indention is the amount of space between text and the boundary of a type object. Indention affects only the selected 
paragraph or paragraphs, so you can easily set different indentions for different paragraphs. 

Paragraph spacing controls set the spacing before and after paragraphs in your text layout.

How to set indents:

1. Using the Type tool, click in the paragraph you want to 
indent (Figure 20).

2. Adjust the appropriate indent values in the Paragraph 
panel. For example, do the following:

• To indent the entire paragraph one pica, type a value 
(such as 1p, which converts to 12-points) in the Left 
Indent box (Figure 21).

• To indent only the first line of a paragraph one pica, 
type a value (such as 1p) in the First Line Left Indent 
box.

• To create a hanging indent of one pica, type a 
positive value (such as 1p) in the Left Indent box and 
type a negative value (such as -1p) in the First Line 
Left Indent box.

Figure 20 Selected paragraph text

Figure 21 Indented paragraph and Paragraph panel

How to adjust paragraph spacing:

1. Insert the cursor in the paragraph you want to change 
(Figure 22), or select a type object to change all of its 
paragraphs. If you don’t insert the cursor in a paragraph 
or select a type object, the setting applies to new text you 
create.

Figure 22 Selected paragraph text
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2. In the Paragraph panel, adjust the values for Space 
Before and Space After (Figure 23).

Note: If a paragraph begins at the top of a column, no 
extra space is added before the paragraph. In this case, 
you can increase the leading of the first line of the 
paragraph or change the inset spacing for the type object. 

Figure 23 Spaced paragraph and Paragraph panel

Laying out text

Threading text between objects, changing text area size, changing margins, creating rows and columns, and wrapping 
text.

Threading text between objects

To thread (or continue) text from one object to the next, you link the objects. Linked type objects can be of any shape; 
however, the text must be entered in an area or along a path (not at a point).

Each area type object contains an in port and an out port, which enable you to link to other objects and create a linked 
copy of the type object (Figure 24). An empty port indicates all the text is visible and the object isn’t linked. An 
arrow in a port indicates the object is linked to another object. A red plus sign in an out port indicates the object 
contains additional text. This remaining unseen text is called overflow text.

Figure 24 Ports on linked type objects
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You can break threads and have the text flow into either the first or the next object, or you can remove all threads and 
have the text stay in place.

How to thread text:

1. Use the Selection tool to select an area type object.

2. Click the in port or the out port of the selected type 
object. The pointer changes to the loaded cursor icon 
(Figure 25).

3. Do one of the following:

• To link to an existing object, position the pointer on 
the object’s path. The pointer changes to an icon of a 
linked cursor. Click the path to link the objects 
(Figure 26). 

• To link to a new object, click or drag on an empty 
part of the artboard. Clicking creates an object of the 
same size and shape as the original; dragging lets 
you create a rectangular object of any size. 

4. To remove or break threads, select a linked type object.

5. Then do any of the following:

• To break the thread between two objects, double-
click the port on either end of the thread (Figure 27). 
The text flows into the first object.

• To release an object from a text thread, choose Type 
> Threaded Text > Release Selection. The text flows 
into the next object.

• To remove all threads, choose Type > Threaded Text 
> Remove Threading. The text stays in place.

Figure 25 Loaded cursor icon

Figure 26 Start anywhere

Figure 27 Double-click a port to break the thread

Manage the text area

You can resize text in different ways, depending on whether you are creating point type, area type, or text along a 
path. There is no limit for the amount of text you can write by using point type, so you do not need to resize the text 
box.

When using the area type tool, you drag an object and type inside the selected area. In this case, the text resizes when 
you resize the object by using the Direct Selection tool.

When you type text along a path, you can thread text between objects if the text does not fit in the selected path. In 
this case also, the text is resized if you resize the path by using the Direct Selection tool.

Note: Make sure the bounding box setting is set to Show Bounding Box. If you are not able to see the bounding box,  
click View > Show Bounding Box.
© 2013 Adobe Systems Incorporated How to work with text 11
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How to resize a text area:

1. To resize, do one of the following:

• Select the type object by using the Selection tool or 
Layers panel, and drag a handle on the bounding box 
(Figure 28). 

• Select the edge or corner of the type path with the 
Direct Selection tool. Then drag to adjust the shape 
of the path (Figure 29). 

• Select the type object by using the Selection tool or 
Layers panel, and choose Type > Area Type Options. 
Enter values for Width and Height, and click OK. Figure 28 Resize by using Selection tool

Figure 29 Resize by using the Direct Selection tool

Change the margin around a text area

When working with an area type object, you can control the margin between the text and the bounding path. This 
margin is referred to as the inset spacing.

How to change the text margin:

1. Select an area type object (Figure 30). 

Figure 30 Type object selected
How to work with text © 2013 Adobe Systems Incorporated
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2. Choose Type > Area Type Options.

The Area Type Options dialog box opens (Figure 31).

3. Specify a value for Inset Spacing, and click OK.

The margin is applied to the area type object (Figure 32).

Figure 31 Area Type Options dialog box

Figure 32 Margin applied to type object

Create rows and columns of text

Applying rows and columns to your text layout helps to improve readability (Figure 33). The optimal line length for 
text is thought to be 50–75 characters per line, including spaces.

Figure 33 Options for resizing rows and columns: Original columns (top), columns resized with Fixed selected 
(middle), and columns resized with Fixed deselected (bottom)
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How to create rows and columns of text:

1. Select an area type object (Figure 34).

2. Choose Type > Area Type Options.

The Area Type Options dialog box opens (Figure 31).

3. In the Rows and Columns sections of the dialog box 
(Figure 35), set the following options:

• Number Specifies the number of rows and columns 
you want the object to contain.

• Span Specifies the height of individual rows and the 
width of individual columns. 

• Fixed Determines what happens to the span of rows 
and columns if you resize the type area. When this 
option is selected, resizing the area can change the 
number of rows and columns but not their width. 
Leave this option deselected if you want row and 
column widths to change when you resize the type 
area.

• Gutter Specifies the distance between rows or 
columns.

4. In the Options section of the dialog box, select a Text 
Flow option to determine how text flows between rows 
and columns: By Rows or By Columns. 

5. Click OK.

Figure 34 Type object selected

Figure 35 Rows and Columns section 

Wrap text around an object

You can wrap area text around any object, including type objects, imported images, and objects you draw in 
Illustrator (Figure 36). If the wrap object is an embedded bitmap image, Illustrator wraps the text around opaque or 
partially opaque pixels and ignores fully transparent pixels.

Figure 36 Area type with wrapped text
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Wrapping is determined by the stacking order of objects, which you can view in the Layers panel by clicking the 
triangle next to the layer name. To wrap text around an object, the wrap object must be in the same layer as the text 
and located directly above the text in the layer hierarchy. You can drag contents up or down in the Layers panel to 
change hierarchy.

How to wrap text:

1. Make sure the following conditions are true for the type 
you want to wrap:

• It is area type (typed in a box).

• It is in the same layer as the wrap object (Figure 37).

• It is located directly under the wrap object in the 
layer’s hierarchy.

Note: If the layer contains multiple type objects, move 
any that you don’t want to wrap around the wrap object 
either into another layer or above the wrap object. 

2. Select the object or objects around which you want the 
text to wrap. 

3. Choose Object > Text Wrap > Make.

You may see a dialog box warning that text will wrap 
around all objects. Click OK.

The text wraps around the object (Figure 38).

4. To set wrap options, choose Object > Text Wrap > Text 
Wrap Options (Figure 39) and specify the following 
options: 

• Offset Specifies the amount of space between the 
text and the wrap object. You can enter a positive or 
negative value.

• Invert Wrap Wraps the text around the reverse side 
of the object.

5. To unwrap text from an object, choose Object > Text 
Wrap > Release.

Figure 37 Layers panel

Figure 38 Wrapped object

Figure 39 Text Wrap Options dialog box

Creating type on a path

Type on a path flows along the edge of an open or closed path. When you enter text horizontally, the characters are 
parallel to the baseline. When you enter text vertically, the characters are perpendicular to the baseline. In either case, 
the text flows in the direction in which points were added to the path.

Path type effects let you distort the orientation of characters on a path. You must first create type on a path before you 
can apply these effects. 
© 2013 Adobe Systems Incorporated How to work with text 15
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How to add type to a path:

1. Do one of the following:

• To create horizontal text along a path, select the Type 
tool or the Type On A Path tool (Figure 40). 

• To create vertical text along a path, select the 
Vertical type tool or the Vertical Type On A Path 
tool. 

2. Use the Control panel, Character panel, or Paragraph 
panel to set text-formatting options such as font, font 
color, stroke, opacity, style, and size.

3. Position the pointer on the path (Figure 41), and click. (It 
doesn’t matter if the path has stroke or fill attributes, 
because Illustrator automatically removes them.) 

Note: If the path is closed rather than open, you must use 
the Type On A Path tool.

4. Enter the text. 

5. When you finish entering text, click the Selection tool to 
select the type object (Figure 42). Alternatively, Ctrl-
click (Windows) or Command-click (Mac OS) the text.

6. To move or flip text along a path, select the path type 
object.

A bracket appears at the beginning of the type, at the end 
of the path, and at the midpoint between the start and end 
brackets. 

7. Position the pointer over the type’s center bracket until a 
small icon appears next to the pointer (Figure 43).

8. Do one of the following:

• To move text along the path, drag the center bracket 
along the path. Hold down Ctrl (Windows) or 
Command (Mac OS) to prevent the type from 
flipping to the other side of the path.

• To flip the direction of text along a path, drag the 
bracket across the path (Figure 44).

Figure 40 Tools panel

Figure 41 Pointer positioned over path

Figure 42 Type object selected

Figure 43 Center bracket icon

Figure 44 Flipped path type object
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How to apply effects to type on a path:

1. Select the path type object. 

2. Choose Type > Type On A Path > Type On A Path 
Options. 

The Type on a Path Options dialog box opens 
(Figure 45).

3.  Select an option from the Effect menu, and click OK.

The effect is applied (Figure 46).

Figure 45 Type On A Path Options dialog box

Figure 46 Gravity effect applied to path type

Convert text to outlines

You can turn type into a set of compound paths, or outlines, that you can edit and manipulate as you would any other 
graphic object (Figure 47). Type as outlines is useful for changing the look of large display type, but it is rarely useful 
for body text or other type at small sizes.

Figure 47 Modifying a letterform A. Original type object B. Type converted to outlines, ungrouped, and modified
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Font outline information comes from the actual font files installed on your system. When you create outlines from 
type, characters are converted in their current positions; they retain all graphics formatting, such as their stroke and 
fill.

When you convert type to outlines, the type loses its hints—instructions built into fonts to adjust their shape so your 
system displays or prints them optimally at a wide range of sizes. If you plan to scale the type, adjust its point size 
before converting.

You must convert all the type in a selection; you cannot convert a single letter within a string of type. To convert a 
single letter into an outline, create a separate type object containing only that letter. 

How to convert text to outlines:

1. Select the type object (Figure 48). 

2. Choose Type > Create Outlines (Figure 49). 

Figure 48 Type object selected

Figure 49 Type converted to outlines

Using the Touch Type tool

The Touch Type tool lets you work creatively with text, creating visually pleasing and powerful messages with just 
text. Each character of text is editable, as if each character were an individual object (Figure 50). You can choose a 
single letter of the alphabet in a word or sentence and play with it by moving, scaling, or rotating it.

Figure 50 Text, formatted normally (left) and text with each character treated individually to accentuate the 
messaging (right)
How to work with text © 2013 Adobe Systems Incorporated
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You can use the Touch Type tool in two ways: manipulate the text by using your mouse and large control handles or 
by using a stylus- or touch-driven multi-touch device (Figure 51). You can use your mouse to work with and 
manipulate objects as easily as you would with a touch-enabled device.

Figure 51 Enhanced control handles around a selected object for the mouse (left) or a multi-touch device (right) 

In this section, you modify the properties of text by using the Touch Type tool, using a mouse cursor. To learn how to 
use the Touch Type tool for a multi-touch device, please see Adobe Illustrator Help.

How to use the Touch Type tool:

1. Pick the Touch Type tool (Shift + T) from the toolbar or 
Control panel (Figure 52).

2. Select a string or character of text.

3. To modify the character (rotate, scale, move), manipulate 
the control handles that appear around the text by using 
touch or a mouse (Figure 53).

Figure 52 Tools panel

Figure 53 Dragging a control handle to scale 
proportionally
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