
Adobe InDesign Guide
How to create interactive documents
You can use Adobe InDesign to create dynamic web content or interactive documents. InDesign supports export to 
web-ready HTML or interactive PDF. 

Interactive web documents

When you generate a web-ready file, it is exported as an HTML page that plays back a SWF file. For SWF files, you 
specify the page size according to monitor resolution (such as 800x600). An exported SWF file is ready for viewing 
in Adobe Flash Player and may include interactive elements such as page transitions, hyperlinks, and navigation 
buttons.

In this guide, you will learn how to create web documents by using InDesign (Figure 1). Steps include how to create 
an interactive button, how to add a page transition, and how to export to SWF format. InDesign includes many more 
options for adding interactivity to your web document. Once you are comfortable with the basics, try experimenting 
with additional features such as rollover and click states for buttons, animating objects by using animation motion 
presets, and modifying the export SWF and HTML options.

Figure 1 Create interactive documents by using InDesign

Document in InDesign before SWF export

Interactive SWF file in web browser
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Consider the following factors when designing your InDesign document for SWF and HTML output.

Document setup factors

• How InDesign pages are converted When you export to SWF, InDesign spreads become separate clips in a 
timeline, like slides in a slide show. Each spread is mapped to a new keyframe. In Flash Player, you advance 
through the spreads of the exported document by pressing arrow keys or clicking interactive buttons.

• Page size When you create a document, you can choose a specific resolution, such as 800x600, from the 
Page Size menu in the New Document dialog box. During export, you can also adjust the scale or resolution 
of the exported SWF file.

Conversion factors

• Color SWF files use RGB color. When a document is exported to SWF, InDesign converts all color spaces 
(such as CMYK and LAB) to sRGB. InDesign converts spot colors to equivalent RGB process colors. To 
avoid unwanted color changes in artwork with transparent text choose Edit > Transparency Blend Space > 
Document RGB. To avoid unwanted color changes in images with transparency, avoid using a lossy 
compression during export.

• Text When exporting to SWF, you can determine whether to output text as Flash text or convert it to outlines 
or pixels. Text exported as Flash Classic Text remains fully searchable in web browsers when saved as SWF 
files.

• Images When you export images to SWF, you can change image compression, JPEG quality, and resolution 
settings during export.

• Transparency Before exporting to SWF, make sure that transparent objects do not overlap any interactive 
element, such as a button or hyperlink. If an object with transparency overlaps an interactive element, the 
interactivity may be lost during export. In some instances, choosing a lossy compression reduces the quality 
of images with transparency. When exporting, choose PNG (Lossless) to improve the quality.

Interactivity factors

You can include buttons, page transitions, hyperlinks, animation, and media files in exported SWF files.

• Buttons For buttons in an exported SWF file, the Next Page and Previous Page actions are especially useful 
controls for playback in Flash Player. However, some actions that work in interactive PDF files have no 
effect in Flash Player. When you choose an action in the Buttons panel, do not select an option from the PDF 
Only section.

• Page Transitions All page transitions work well in Flash Player. In addition to page transitions that appear 
when you turn the page, you can add an interactive page curl during export that lets you drag corners of 
pages to turn them.

• Hyperlinks Create links to websites or to other pages in the document. 

• Movies and sound clips Movies and sound clips are included in an exported SWF file if they’re in SWF 
format for movies and MP3 format for sound clips.
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To create interactive files for the web:

1. Start InDesign and choose File > New > Document.

The New Document dialog box appears (Figure 2).

2. When creating a document intended for the web, choose 
Web from the Intent menu in the New Document dialog 
box.

3. Enter 2 or more pages in the Number Of Pages box.

4. Choose the default 800 x 600 from the Page Size menu.

5. Click OK to close the New Document dialog box.

First, you need to create an interactive button that allows 
users to move from page to page in the exported SWF 
file. 

6. Import an image, draw a shape, or add text to the 
document.

7. Use the Selection tool (Figure 3) to select the image, 
shape, or text frame that you want to convert to a button.

8. Choose Window > Interactive > Buttons And Forms. 

The Buttons And Forms. panel appears (Figure 4).

Note: Sample buttons are also available. Click the 
Buttons And Forms panel menu to access the Sample 
Buttons And Forms panel (Figure 5), and scroll down for 
buttons. You can drag predefined navigation buttons and 
form elements into your document and attach actions to 
these instead of an existing image, shape, or text frame in 
the document.

9. Click the Convert To Button icon in the Buttons And 
Forms panel (Figure 4).

The object is converted to a button and the Buttons And 
Forms panel is updated.

10. Name the new button in the Name text box and confirm 
that the Hidden Until Triggered option is not selected.

Next, you need to define the mouse event and assign an 
action for the button. 

Figure 2 New Document dialog box

Figure 3 Tools panel

Figure 4 Buttons And Forms panel

Figure 5 Sample Buttons and Forms panel
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11. Click the Event menu, and select from the available 
options (Figure 6). An event defines how actions are 
activated.

• On Release Or Tap When the button is released after 
a click or a tap. This is the most commonly used 
event, because it gives the user one last chance to 
drag the cursor or touch off the button and not 
activate the action.

• On Click When the button is clicked (without being 
released). Unless you have a specific reason for 
using On Click, it’s preferable to use On Release so 
that users have a chance to cancel the action.

• On Roll Over When the mouse pointer or touch 
action enters the button area defined by the button’s 
bounding box.

• On Roll Off When the mouse pointer or touch action 
exits the button area.

12. Click the Add New Action button, and choose an action 
to assign to the event you just selected. 

For example, if you are working with a multipage spread, 
you might choose Go To Next Page from the list of 
destination options (Figure 7).

If you choose Go To URL, specify the web page address. 
Some actions, such as Go To Next View, do not have 
additional settings.

13. With the object still selected, choose Window > 
Interactive > Page Transitions to add page transitions 
such as wipes or dissolves. 

The Page Transitions panel appears (Figure 8).

14. From the Transition menu, select Page Turn (SWF Only).

You can move your mouse over the Preview area to see 
how the transition works.

15. Choose File > Save.

16. To export the document to SWF format, choose File > 
Export. 

The Export dialog box appears.

Figure 6 Event menu

Figure 7 Add New Action menu

Figure 8 Page Transitions panel
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17. Choose Flash Player (SWF) from the Save As Type 
(Windows) or Format (Mac OS) menu, and click Save.

The Export SWF dialog box appears (Figure 9).

You can specify the export options in the Export SWF 
dialog box. 

For this example, accept the default export options. For 
more information about Export SWF options, see “SWF 
export options” in InDesign Help.

18. Confirm the Generate HTML File option is selected.

With this option selected, an HTML page is generated 
that plays back the SWF file. This option is especially 
useful for quickly previewing the SWF file in your web 
browser.

19. Click OK. 

The Generate Flash Player (SWF) progress dialog box 
appears and the file is processed.

The file opens in your default browser. 

20. Test the button interactions in your interactive SWF file 
(Figure 10).

Figure 9 Export SWF dialog box

Figure 10 Testing hyperlinks in the browser
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Animation

You can use Animation effects to make objects move in InDesign documents you export as SWF files. For example, 
you can apply a motion preset to drop a heading in from the top or to make an image of an automobile appear to move 
in from the right side of the screen and screech to a halt (Figure 11). Use the following tools and panels to animate 
documents.

• Animation panel Apply a motion preset and edit settings such as duration and speed.

• Direct Selection tool and Pen tool Edit the path on which the animated object travels.

• Timing panel Determine the order in which objects on a page are animated.

• Preview panel View the animation in an InDesign panel.

Figure 11 Examples of animation options

For more detailed information about how to use animation in InDesign, refer to InDesign Help.

Animating a document with motion presets

Motion presets are pre-made animations that you can apply to objects quickly. Use the Animation panel to apply 
motion presets and change animation settings such as duration and speed. The Animation panel also lets you specify 
when an animated object plays.

These motion presets are the same as those found in Adobe Flash Professional. You can import any custom motion 
preset created in Flash Professional, and you can save motion presets you create and edit for sharing with others.

Note: Animation features are supported only when exporting to Adobe Flash Player (SWF). They are not supported 
when exporting to Interactive PDF. To add animation effects to a PDF file, export a selection as a SWF file from 
InDesign and place that SWF file in the InDesign document.

Page title drops in 
from the top

Automobile moves in 
from the right and 
stops
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Motion preset options

Motion preset options appear in the Animation panel (Figure 12). To display the Animation panel, choose Window > 
Interactive > Animation. Click the disclosure triangle beside Properties to display advanced settings.

• Name Specify a name for the animation. Descriptive names are especially useful when setting up an action 
that triggers the animation.

• Preset Choose from a list of predefined motion settings.

• Event(s) By default, On Page Load is selected, which means the animated object plays when the page opens 
in the SWF file. Choose On Page Click to trigger the animation when readers click the page. Choose On 
Click (Self) or On Roll Over (Self) to trigger the animation when readers click the object or move the mouse 
over it. If you create a button action that triggers the animation, On Button Event is selected.  You can 
specify multiple events to start the animation. If you select the On Roll Over (Self) event, you can also select 
Reverse On Roll Off. This option reverses the action of the animation when the mouse moves off the object.

• Create Button Trigger Click this button to trigger the animation from an existing object or button. After you 
click Create Button Trigger, click the object that triggers the animation. The object is converted to a button, 
if necessary, and the Buttons panel appears.

• Duration Specify how much time it takes for the animation to occur.

• Play Specify the number of times the animation is played, or select Loop to cause the animation to play 
repeatedly until it’s stopped.

• Speed Choose an option to determine whether the animation speed is a steady rate (None), starts slowly and 
speeds up (Ease In), or slows down at the end (Ease Out). 

Figure 12 Animation panel

Preset preview

Preset menu

Animate 
options 
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Create Button Trigger 
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The following options are available when Properties is expanded (Figure 12).

• Animate Choose one of the following settings from the Animate menu. Each setting is illustrated in the 
example (Figure 13).

◦ From Current Appearance uses the object’s current properties (scale percentage, rotation angle, and 
position) as the starting point of the animation. 

◦ To Current Appearance uses the object’s properties as the ending point of the animation. This option is 
especially useful in slide shows. For example, objects that fly in from off the page can appear on the 
page rather than on the pasteboard, improving the appearance of the printed document. 

◦ To Current Location uses the current object’s properties as the starting point of the animation and the 
object’s position as the ending point. This option is similar to From Current Appearance, except that the 
object finishes in its current location and the motion path is offset. This option is especially useful for 
certain presets, such as blurs and fades, to prevent the object from appearing in an undesirable state at 
the end of the animation. 

Figure 13 Animate settings

Note: To display the proxy at the end of the motion path, click the Show Animation Proxy at the bottom of 
the Animation panel. A proxy is the visual representation of the object at the end of a motion path.

• Rotate Specify a rotation angle that the object completes during the animation.

• Origin Use the proxy to specify the origin point of the motion path on the animated object.

• Scale Specify a percentage value to determine whether the object increases or decreases in size during 
playback.

• Opacity Choose an option to determine whether the animation remains solid (None), gradually becomes 
visible (Fade In), or gradually becomes invisible (Fade Out).

• Visibility Select Hide Until Animated or Hide After Animating to make an object invisible before or after 
playback.

To animate a document with motion presets:

1. Place the object you want to animate in your document.

2. Choose Window > Interactive > Animation.

The Animation panel appears (Figure 12).

Object and path before 
animation

From Current Appearance To Current Appearance To Current Location

Proxy
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3. Choose a motion preset from the Preset menu, such as 
Fly In From Right.

A green motion path appears, indicating the start, finish, 
and travel path of the object (Figure 14).

4. Specify other motion preset options such as Event(s), 
Duration, Play, and Speed.

5. To edit the motion path, use the Pen tool and Direct 
Selection tool.

6. (Optional) If you place more than one object in the 
document, use the Timing panel (Window > Interactive > 
Timing) to determine the order of when animated objects 
play (Figure 15).

For example, you can change one set of animations that 
occur when the page is loaded, and then change another 
set of animations that occur when the page is clicked.

Animated objects are listed in the order they were 
created. Animations listed for the Page Load event occur 
sequentially by default. Animations listed for the Page 
Click event are played in sequence each time the page is 
clicked.

7. Choose Window > Interactive > SWF Preview to preview 
the animation in InDesign (Figure 16).

8. If you made changes to the motion preset and you want to 
save the custom preset for other uses, choose Save from 
the Animation panel menu.

Note: You can also delete, duplicate, import, or export 
motion presets from the Animation panel menu.

9. Type a name for the preset and click OK.

Figure 14 Motion path

Figure 15 Timing panel

Figure 16 SWF Preview panel

Interactive PDF documents

Creating an interactive PDF document is a good way to create an dynamic slide show. As with interactive SWF 
documents, you can create interactive PDF documents with buttons, movies and sound clips, hyperlinks, bookmarks, 
and page transitions. You can also set up documents in InDesign and convert them to forms in Acrobat. 

In this guide you will learn how to create dynamic PDF documents by using InDesign. Steps include how to create a 
bookmark, insert a URL link, apply a decorative page transition, and export to PDF format. Once you are familiar 
with the basics, try adding movies and sound clips into your dynamic PDF document.

Play 
preview

Clear 
preview
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Create interactive documents for PDF

You can export Adobe PDF documents that include the following interactive features.

• Bookmarks Bookmarks you create in the InDesign document appear in the Bookmarks tab on the left side of 
the Adobe Acrobat or Adobe Reader window. Each bookmark jumps to a page, text, or graphic in the 
exported PDF file. 

• Movies and sound clips You can add movies and sound clips to a document, or you can link to streaming 
video files on the Internet. These movies and sound clips can be played back in the exported PDF file. 

• Hyperlinks In an exported PDF document, clicking a hyperlink jumps to another location in the same 
document, to a different document, or to a website. You can create hyperlinks to pages, URLs, text anchors, 
e-mail addresses, and files. If you create a hyperlink to a page or text anchor in a different document, make 
sure the exported files appear in the same folder.

• Cross-references A cross-reference refers readers from one part of your document to another in the exported 
PDF file. Cross-references are especially useful in user guides and reference manuals. When you export a 
document with cross-references to PDF, the cross-references act as interactive hyperlinks. 

• Page transitions Page transitions apply a decorative effect, such as a dissolve or wipe, when you turn the 
page in the exported PDF while in Full Screen mode.

To create an interactive document for PDF:

1. Start InDesign and choose File > New > Document.

The New Document dialog box appears.

2. When creating a document intended for printing, accept 
the default Print from the Intent menu in the New 
Document dialog box.

3. Enter 2 or more pages in the Number Of Pages box.

4. Choose Letter from the Page Size menu.

5. Click OK to close the New Document dialog box.

The first step is to create a bookmark to another section 
of the document. 

6. Choose Window > Interactive > Bookmarks. 

The Bookmarks panel appears (Figure 17).

7. Select text in your document. 

By default, the text you select becomes the bookmark 
label.

8. Do one of the following to create the bookmark:

• Click the Create New Bookmark button in the 
Bookmarks panel.

• Choose New Bookmark from the panel menu.

Figure 17 Bookmarks panel

Bookmarks 
panel menu

Create New 
Bookmark
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9. Accept the default bookmark name, or rename the 
bookmark.

Bookmarks appear in the Bookmarks navigation pane 
when you open the exported PDF file in Adobe Reader or 
Acrobat.

Note: You can use the Bookmarks panel menu to rename 
and delete bookmarks. Drag bookmarks in the panel to 
rearrange them. You can nest a list of bookmarks to show 
a relationship between topics. Nesting creates a parent/
child relationship. You can expand and collapse this 
hierarchical list as desired. Changing the order or nesting 
order of bookmarks does not affect the appearance of 
your actual document.

Next, you create a hyperlink that takes you to an external 
website destination.

10. Choose Window > Interactive > Hyperlinks.

The Hyperlinks panel appears (Figure 18).

11. Select the text, frame, or graphic you want to be the 
hyperlink’s source.

12. Do one of the following to create the hyperlink:

• Click the Create New Hyperlink button in the 
Hyperlinks panel.

• Choose New Hyperlink in the Hyperlinks panel 
menu. 

The New Hyperlink dialog box appears (Figure 19).

Note: Use the Hyperlinks panel menu to edit, delete, 
reset, or locate hyperlinks.

13. Choose URL from the Link To menu.

14. In the URL text box, type or paste the destination URL 
for the hyperlink.

15. Specify appearance options, such as the following:

Character Style Choose a character style to apply to the 
hyperlink source. The Character Style option is available 
only if the hyperlink source is selected text, not a selected 
frame or graphic.

Type Select Visible Rectangle or Invisible Rectangle.

Highlight Select Invert, Outline, Inset, or None. These 
options determine the appearance of the hyperlink when 
readers click it in the PDF file.

Color Select a color for the visible hyperlink rectangle.

Width Select Thin, Medium, or Thick to determine the 
thickness of the hyperlink rectangle.

Style Select Solid or Dashed to determine the appearance 
of the hyperlink rectangle.

Figure 18 Hyperlinks panel

Figure 19 New Hyperlink dialog box
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16. Click OK.

Note: If a URL hyperlink isn’t working in the exported 
PDF, the problem may be that the hyperlink is a shared 
destination. Double-click the hyperlink in the Hyperlinks 
panel, choose URL from the Link To menu, deselect 
Shared Hyperlink Destination, and click OK.

17. Choose File > Export.

18. Specify a name and location for the file.

19. For Save As Type (Windows) or Format (Mac OS), 
choose Adobe PDF (Interactive).

20. Click Save.

The Export To Interactive PDF dialog box appears 
(Figure 20).

21. Select the Open In Full Screen Mode option to ensure the 
interactive PDF fills the entire screen when it opens.

22. Click OK.

The Generating PDF progress dialog box appears and the 
file is processed.

The file opens in your default application for PDF files.

Note: If you are asked whether you want to view the 
document in Full Screen mode, click Yes.

23. Click anywhere in the PDF document to advance to the 
next page.

24. Test the hyperlinks you created (Figure 21).

Note: If you receive a warning that the document is 
trying to connect to a website, click Allow.

25. Close Full Screen mode by pressing Ctrl+L (Windows) 
or Command+L (Mac OS) or Esc.

26. To display the navigation pane in Adobe Acrobat or 
Adobe Reader, do one of the following:

• Click any panel button on the left side of the work 
area to display that panel.

• Choose View > Show/Hide > Navigation Panes > 
Show Navigation Pane.

27. Test the bookmarks you created (Figure 22).

Figure 20 Export To Interactive PDF dialog box

Figure 21 Testing hyperlinks in Acrobat

Figure 22 Bookmarks in the navigation pane in 
Acrobat
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