
Adobe InDesign Guide
How to use styles, lists, columns and table of contents
Whether you’re working with long or short documents, styles can help you keep text formatting consistent. Styles are 
a collection of text attributes you can save and apply to new text. A consistent design, especially in longer documents, 
helps readers navigate through your document and also helps maintain a clean, appealing style and design layout.

Adobe InDesign has two kinds of styles:

• Character styles collect information about the way textual characters appear: font size, font family, font 
style (bold, italic), tracking, and leading. Access by choosing Window > Styles > Character Styles. 

• Paragraph styles include everything in character styles and also information about text orientation 
(horizontal and vertical), tab stops, and other paragraph attributes. You can apply a paragraph style to one 
paragraph or a range of paragraphs. Access by choosing Window > Styles > Paragraph Styles.

Use character styles only when you know you will be applying styles to a few words rather than to the whole 
paragraph. Otherwise, paragraph styles are generally more versatile.

Other common text features you may use in laying out InDesign documents will be bulleted and numbered list styles, 
using columns to format paragraphs, and including a table of contents.

This guide covers the following topics:

• Creating paragraph styles based on existing formatting and from scratch

• Applying and editing paragraph styles

• Creating and applying character styles

• Creating bulleted and numbered list styles

• Applying columns in a text frame

• Adding a table of contents to the first page of a document

Creating styles based on existing formatting

One of the easiest and fastest ways to create a style is to base it on text you have already formatted. This way, you can 
see how the text appears on the page before saving the text attributes as a style.

To create a style based on existing formatting:

1. Start InDesign, create a new document, and create a text 
frame by using the Type tool.

2. Add text to the text frame and apply formatting.

The text in the example (Figure 1) has the following 
formatting:

• Font family: Copperplate Gothic Bold

• Font size: 36 points

• Font color: Red

3. Select the text by using the Type tool.

4. Choose Window > Styles > Paragraph Styles to display 
the Paragraph Styles panel (Figure 1).

Figure 1 Paragraph Styles panel

Create New Style Panel menu
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5. With text still selected, click the Create New Style button 
at the bottom of the Paragraph Styles panel.

The new style appears in the Paragraph Styles panel 
(Figure 2).

6. Select the style and choose Style Options from the 
Paragraph Styles panel menu (Figure 3).

The Paragraph Style Options dialog box appears 
(Figure 4).

7. In the Style Name text box, enter a name for the style.

You will later use this name to apply the style, so make 
the name as meaningful as possible.

For example, you might name the style after its function 
(First-Level Heading) or its appearance (Copperplate, 
36pt, Red).

8. Click OK to close the Paragraph Style Options dialog 
box.

The renamed style is now available in the Paragraph 
Styles panel (Figure 5).

Figure 2 New style created in the Paragraph 
Styles panel

Figure 3 Paragraph Styles panel menu

Figure 4 Paragraph Style Options dialog box

Figure 5 Style renamed
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Creating a style from scratch

There may be a specific look and feel for a character or paragraph style you want to achieve. If so, you can create a 
custom style. 

To create a custom style:

1. If the Paragraph Styles panel is not open, choose Window 
> Styles > Paragraph Styles to display it.

2. Choose New Paragraph Style from the Paragraph Styles 
panel menu (Figure 3).

The New Paragraph Style dialog box appears (Figure 6).

3. In the Style Name text box, enter a name for the style.

You will later use this name to apply the style, so make 
the name as meaningful as possible. 

For example, you might name the style after its function 
(Second-Level Heading) or its appearance (Tahoma, 
18pt, blue).

4. In the General category of the New Paragraph Styles 
dialog box (which appears by default), you can set the 
following options:

• In the Based On pop-up menu, choose a style on 
which to base the current style. If you base this style 
on an existing style, all changes made to the “base” 
style—known as the parent style—will affect the 
new style—known as the child style. For more 
information on parent and child styles, see InDesign 
Help.

• In the Next Style pop-up menu, you can designate a 
style to follow the style you’re defining. If you set 
this option, the next style will automatically be 
applied to the next paragraph after you press Enter 
(Windows) or Return (Mac OS) at the end of a 
paragraph to which the style has been applied. For 
example, many headings are followed by “normal” 
or “body text” styles. If you set a style called “body 
text” as the next style for a heading, body text will be 
applied automatically when you press Enter or 
Return (Figure 7).

Figure 6 General category of New Paragraph Style 
dialog box

Figure 7 Next style
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5. Click other categories on the left side of the New 
Paragraph Style dialog box to set attributes in other 
categories.

For example, you might make changes in the following 
categories:

• Basic Character Formats: Font family, font size, 
font style, kerning, leading, tracking, case, and so on.

• Advanced Character Formats: Horizontal and 
vertical scale, baseline shift, and skew.

• Indents And Spacing: Text indent, space after text, 
alignment, and so on. Use the Align To Grid option 
to align all text to the document grid.

• Character Color: Sets character color from a list that 
includes any swatches you have created.

6. When you are satisfied with your changes, click OK to 
create the style.

The New Paragraph Style dialog box closes and the new 
style is available in the Paragraph Styles panel.

Applying a style

Once you create a style by using any method, you can apply that style to new or existing text.

To apply a style:

1. Create a text frame by using the Type tool.

2. Add text to the text frame.

3. If the Paragraph Styles panel is not open, choose Window 
> Styles > Paragraph Styles to display it.

4. Select the text by using the Type tool (Figure 8).

5. In the Paragraph Styles panel, click a style to apply it.

6. Click anywhere to deselect the text.

The style’s formatting has been applied to the text 
(Figure 9). Figure 8 Selecting the text to apply a style

Figure 9 Style applied
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Editing a style

Even after you apply a style to text, you can make changes to the style. These changes are applied automatically to all 
text with that style applied.

To edit a style:

1. If the Paragraph Styles panel is not open, choose Window 
> Styles > Paragraph Styles to display it.

2. Click a style to select it.

Ideally, this should be a style you have previously applied 
to text

3. Choose Style Options from the Paragraph Styles panel 
menu (Figure 3).

The Paragraph Style Options dialog box appears 
(Figure 10).

4. On the left side of the Paragraph Style Options dialog 
box, click the Basic Character Formats option to expand 
the Basic Character Formats category.

5. Change some of the following attributes:

• Font family

• Font size

• Case

• Leading

6. Click OK to apply the changes.

Any text with the style applied has changed.

The text in the example (Figure 11) has been changed to 
the following:

• Font family: Times New Roman

• Font size: 18 points

• Case: Small Caps

Figure 10 Paragraph Style Options dialog box

Figure 11 Style edits applied

Basic Character Formats category
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Creating and applying character styles

Character styles can include only those attributes you can apply to characters. Character styles are useful when you 
want to apply special formatting to a word or phrase within a paragraph—even a paragraph that has a paragraph style 
applied to it. Character styles override paragraph styles.

To create a character style:

1. Choose Window > Styles > Character Styles to display 
the Character Styles panel (Figure 12).

2. Choose New Character Style from the Character Styles 
panel menu (Figure 13). 

The New Character Style dialog box appears 
(Figure 14). 

The set of options on the left side is more limited than in 
the New Paragraph Style dialog box.

3. In the Style Name text box, enter a name for the new 
character style. 

You will later use this name to apply the style, so make 
the name as meaningful as possible. 

For example, you might name the style after its function 
(Text Highlight) or its appearance (Tahoma 14 pt Red).

4. Click categories on the left side of the dialog box to set 
attributes in other categories. 

For example, you might make changes in the following 
categories:

• Basic Character Formats: Font family, font size, 
font style, kerning, leading, tracking, case, and so on.

• Advanced Character Formats: Horizontal and 
vertical scale, baseline shift, and skew.

• Character Color: Sets character color from a list that 
includes any swatches you have created. 

5. When you are satisfied with your changes, click OK to 
create the character style

Figure 12 Character Styles panel 

Figure 13 Character Styles panel menu

Figure 14 New Character Style dialog box
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To apply a character style:

1. Create a text frame by using the Type tool.

2. Add text to the text frame. 

3. If the Character Styles panel is not open, choose Window 
> Styles > Character Styles to display it. 

4. Select one or two words of the text by using the Type tool 
(Figure 15). 

5. In the Character Styles panel, click the style to apply it. 

6. Click anywhere to deselect the text.

The style’s formatting has been applied to the selected 
text (Figure 16).

The style is not automatically applied to the entire 
paragraph as it is when you apply a paragraph style.

Figure 15 Applying a character style

Figure 16 Character style applied

How to create bulleted and numbered list styles

In bulleted lists, each paragraph begins with a bullet character. In numbered lists, each paragraph begins with an 
expression that includes a number or letter and a separator such as a period or parenthesis (Figure 17). The numbers 
in a numbered list are updated automatically when you add or remove paragraphs in the list. You can change the type 
of bullet or numbering style, the separator, the font attributes and character styles, and the type and amount of indent 
spacing.

A quick way to create a bulleted or numbered list is to type the list, select it, and then click the Bulleted List or 
Numbered List button in the Control panel. These buttons let you turn the list on or off and switch between bullets 
and numbers. You can also make bullets and numbering part of a paragraph style and construct lists by assigning 
styles to paragraphs.

Figure 17 Bulleted list (left) and numbered list (right)
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How to format a bulleted or numbered list:

1. Using the Type tool, select the set of paragraphs that will 
become the list (Figure 18), or click to place the insertion 
point where you want the list to begin.

2. Click the Bulleted List button or the Numbered List 
button in the Control panel (in Paragraph mode) 
(Figure 19). 

The selected text is formated (Figure 20).

3. To reformat bulleted or numbered paragraphs, use the 
Type tool to select the text.and choose Bullets And 
Numbering from the Control panel menu (in Paragraph 
mode)

4. In the Bullets And Numbering dialog box(Figure 21), do 
any of the following:

• Change the bullet character.

• Change the numbered list options.

• Choose a style for the numbers or bullets from the 
Character Style list.

To change the position of the bullet or number, specify 
any of the following:

• Alignment Left-aligns, centers, or right-aligns the 
bullets or numbers within the horizontal space 
allotted for numbers.

• Left Indent Specifies how far the lines after the first 
line are indented.

• First Line Indent Controls where the bullet or 
number is positioned.

• Tab Position Activates the tab position to create 
space between the bullet or number and the start of 
the list item.

Figure 18 Selected text

Figure 19 Control panel

Figure 20 Text reformatted into Numbered list

Figure 21 Bullets and Numbering dialog box

Numbered ListBulleted List Control panel 
menu
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How to create columns in a text frame 

You can use Text Frame Options to change settings such as the number of columns in a text frame, the vertical 
alignment of text within the frame, or the inset spacing, which is the distance of the margins between the text and the 
frame.

You can also make a paragraph span across multiple columns in a text frame to create a straddle head effect 
(Figure 22). You can choose whether a paragraph spans all columns or a specified number of columns. When a 
paragraph is set to span across columns in a multicolumn text frame, any text before the spanning paragraph becomes 
balanced as a result. You can also split a paragraph into multiple columns within the same text frame (Figure 22).

Figure 22 A heading that spans two columns (left) and a paragraph split into two column (right)

How to add columns to a text frame:

1. Using the Selection tool, select a frame, or using the Type 
tool, click inside the text frame or select text.

2. Choose Object > Text Frame Options.

The Text Frame Options dialog box opens (Figure 23).

3. Use the Number field to specify the number of columns. 
You can also set the width of each column, and the 
spacing between each column (gutter) for the text frame.

Figure 23 Text Frame Options dialog box
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4. (Optional) Select Balanced Columns to make text even at 
the bottom of a multi-column text frame (Figure 24).

5. Click OK to close the Text Frame Options dialog box.

Figure 24 Before and after balancing columns

How to span a paragraph across columns:

1. Use the Type tool to select text the paragraph that you 
want to span across columns (Figure 25).

2. Choose Type > Paragraph.

The Paragraph panel opens (Figure 26).

3. Choose Span Columns from the Paragraph panel menu.

The Span Columns dialog box opens.

4. Choose Span Columns from the Paragraph Layout menu.

The Span Columns settings are available (Figure 27).

5. Choose the number of columns you want the paragraph 
to span from the Span menu. Choose All if you want the 
paragraph to span across all the columns.

6. (Optional) To add extra space before or after the span 
paragraph, specify Space Before Span and Space After 
Span values.

7. Click OK to close the Span Columns dialog box.

The selected text spans across indicated columns 
(Figure 28).

Figure 25 Selected text

Figure 26 Paragraph panel

Figure 27 Span Columns dialog box

Figure 28 Heading spanning two columns

Panel menu
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How to split a paragraph into columns:

1. Use the Type tool to select text the paragraph that you 
want to span across columns (Figure 29).

2. Choose Type > Paragraph.

The Paragraph panel opens (Figure 26).

3. Choose Span Columns from the Paragraph panel menu.

The Span Columns dialog box opens.

4. Choose Split Columns from the Paragraph Layout menu.

The Split Columns settings are available (Figure 30).

5. (Optional) Specify the following options as needed:

• Sub-columns Choose the number of columns you 
want the split the paragraph into.

• Space Before Split / Space After Split Add space 
before or after the split paragraph.

• Inside Gutter Determine the space between the split 
paragraphs.

• Outside Gutter Determine the space between the 
outside of the split paragraphs and the margins.

6. Click OK to close the Span Columns dialog box.

The selected text spans across indicated columns 
(Figure 31).

Figure 29 Selected text

Figure 30 Span Columns dialog box

Figure 31 Paragraph spanning two columns

How to create a Table of Contents

A table of contents (TOC) can list the contents of a book, magazine, or other publication; display a list of illustrations, 
advertisers, or photo credits; or include other information to help readers find information in a document or book file. 
One document may contain multiple tables of contents—for example, a list of chapters and a list of illustrations.

Each table of contents is a separate story consisting of a heading and a list of entries sorted either by page number or 
alphabetically. Entries, including page numbers, are pulled directly from content in your document and can be 
updated at any time.

The process for creating a table of contents requires three main steps. First, create and apply the paragraph styles 
you’ll use as the basis for the TOC. Second, specify which styles are used in the TOC and how the TOC is formatted. 
Third, flow the TOC into your document.
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Generate a table of contents

Before you generate a table of contents, you will have already created a multi-page layout with chapter titles, section 
headings, and other content. You must decide which paragraphs should be included in the table of contents (such as 
chapter titles and section headings), and then define paragraph styles for each. Make sure that these styles are applied 
to all appropriate paragraphs in the document.

When you generate the table of contents, you can also use custom paragraph and character styles to format the table 
of contents (Figure 32). 

Figure 32 Table of contents without paragraph styling (left) and with paragraph styling applied to entries (right) 

How to generate a table of contents:

1. If you’re creating a table of contents for a single 
document, you will want to add a new page at the 
beginning of the document. Choose Layout > Pages > 
Insert Pages.

The Insert Pages dialog box opens (Figure 33).

2.  In the Insert menu, select Before Page, and confirm the 
page number text box is set to page 1.

3. Click OK to close the Insert Pages dialog box.

The new page is added to the layout, this is where you 
will be placing your table of contents.

4. Choose Layout > Table Of Contents.

The Table of Contents dialog box opens (Figure 34)

Figure 33 Insert Pages dialog box

Figure 34 Table of Contents dialog box
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5. In the Title box, type a title for your TOC (such as 
Contents or List of Figures). This title will appear at the 
top of the table of contents. To format the title, choose a 
style from the Style menu. For example, in Figure 35 the 
default TOC Title option is selected.

6. Determine which content you want to include in the table 
of contents by selecting paragraph styles in the Other 
Styles list and clicking the Add button to move the 
selection to the Include Paragraph Styles list (Figure 36).

Next, you need to define how the selected Paragraph 
Styles will be formatted in the TOC. 

7. Select the first item in the Included Paragraph Styles list. 

The selected style appears in the Style area of the Table 
of Contents dialog box (Figure 37). 

8. Set the Entry Style for the selected paragraph style. For 
example, in Figure 37, the Section Heading Entry Style 
is set to the default TOC Body Text.

9. Repeat setting Entry Style for each of the items in the 
Included Paragraph Styles list.

10. Click OK to close the Table of Contents dialog box.

The table of contents is generated, but the entries still 
need to be styled with dots or tab leaders separating the 
entry from its associated page number (Figure 38). 

Figure 35 Style menu

Figure 36 Including styles in the Table of Contents

Figure 37 Setting Entry Style for selected 
Paragraph Styles

Figure 38 Generated table of contents
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How to create TOC entries with tab leaders:

1. Choose Window > Styles > Paragraph Styles to display 
the Paragraph Styles panel (Figure 39). 

2. Double-click the Paragraph Style you used for the body 
entries of the TOC. For example, in the previous section, 
you used the TOC Body Text to style all TOC entries.

The Paragraph Style Options dialog box opens 
(Figure 40).

3. Click Tabs.

4. Select the right-justified tab icon, and then click on the 
ruler to position the tab stop (Figure 41).

5. For Leader, type a period (.).

6. Click OK to close the Paragraph Style Options dialog 
box. 

The table of contents paragraph style is reformatted with 
a tab leader (Figure 42).

Next, the entry levels need to be refined so that the 
heading levels are indented from each other.

Figure 39 Paragraph Styles panel

Figure 40 Paragraph Style Options dialog box

Figure 41 Tabs section of Paragraph Style Options

Figure 42 Table of contents with tab leader

Panel menu

Right-Justified Tab Click on ruler to place tab
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7. In the Paragraph Styles panel, select the style you used 
for your TOC entries (Figure 39).

8. Choose Duplicate Style from the Paragraph Styles panel 
menu.

The Duplicate Paragraph Style dialog box opens 
(Figure 43).

9. Rename the style in the Style Name text box. For 
example, consider defining the level of the entry for 
which the style is named. In this example, the Style name 
is changed to TOC Body Text level 2.

10. Click Indents and Spacing.

11. Click the Left Indent up arrow or enter a dimension in the 
number box to add space to the left-hand margin of the 
style (Figure 44).

12. Click OK to close the Duplicate Paragraph Style dialog 
box.

13. Choose Layout > Table Of Contents.

The Table of Contents dialog box opens.

14. In the Include Paragraph Styles area, choose the style that 
you want to update with the redefined indented style.

15. In the Style area, select the just-created paragraph style to 
define the Entry Style (Figure 45).

Figure 43 Duplicate Paragraph Styles dialog box

Figure 44 Paragraph Style Options dialog box

Figure 45 Setting the Entry Style for a second-
level heading
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16. Click OK to close the Table Of Contents.

The second level heading in the table of contents is 
updated (Figure 46).

17. Repeat steps 7 to 16 to redefine any third or fourth level 
entry styles you have listed in your table of contents. 
Consider adding additional formatting to the styles such 
as increased indentation and italics to create visual 
differentiation among the levels (Figure 47).

Figure 46 Updated TOC second-level heading

Figure 47 Updated TOC third-level heading

Update and edit a table of contents

The table of contents is like a snapshot of content in your document. If page numbers in your document change, or if 
you edit headings or other elements associated with table of contents entries, you’ll need to regenerate the table of 
contents to update it.

How to update a table of contents:

1. Select or place the insertion point in the text frame containing the table of contents, and then choose Layout > 
Update Table Of Contents.

2. If you have multiple tables of contents in your document, such as a list of figures and a list of tables, select the 
text frame containing a different list, and then choose Layout > Update Table Of Contents.
How to use styles, lists, columns and table of contents © 2013 Adobe Systems Incorporated

This document requires Adobe InDesign CC, June 2013. Technical instructions may differ depending on your version.


	How to use styles, lists, columns and table of contents
	Creating styles based on existing formatting
	Creating a style from scratch
	Applying a style
	Editing a style
	Creating and applying character styles
	How to create bulleted and numbered list styles
	How to create columns in a text frame
	How to create a Table of Contents
	Generate a table of contents
	Update and edit a table of contents



