
Adobe Flash Professional Guide
How to resize content for multiple screens
Many mobile devices are on the market and their screen sizes vary. A common challenge when developing mobile 
applications (or web content for mobile devices) is to make your content look the same (or at least look good) on 
every device. You want to make sure your content fits each screen perfectly. You can meet this challenge in a couple 
of ways: You can design mobile applications that target a specific device and screen size—reusing and resizing 
content to build separate versions for each device. Or you can use ActionScript and auto-scaling features to create a 
single version that automatically scales to match each screen. 

Creating and sizing content for multiple screens

If you’re creating multiple versions of the same content and adjusting a design to match multiple screen sizes, you 
can use the following features in Adobe Flash Professional to adapt your content for each device. 

• Use Save As to create a new file based on an existing file.

• Use Adaptive Scaling to resize content objects automatically to match the screen size.

• Adjust content objects manually by using Free Transform or by changing values in the Properties panel.

• Copy and paste layers and content from one Flash Professional document to another.

To save an existing document as a new file:

1. Open the Flash Professional document you want to adapt 
for multiple screens.

2. Select File > Save As.

The Save As dialog box appears.

3. Enter a name for the new document and click Save.

You now have an exact copy of the original file. You can 
adapt the file for another screen by changing the 
document’s publish settings, adjusting the document 
dimensions, and scaling its content.

4. In the Publish section of the Properties panel, select a 
new target runtime from the Target menu (Figure 1). 

In this example, we designed the application for Android 
mobile devices. You can change the target to AIR For 
IOS to create a version for the Apple iPhone or other iOS 
device.

After setting up the new document, you need to edit the 
document dimensions to match those of the new target 
screen. 

When you change document dimensions, you can use 
Adaptive Scaling to help resize your content to match.

Figure 1 Properties panel, Publish section 
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To use adaptive and manual scaling to resize content:

1. Select Edit > Preferences (Windows) or Flash > 
Preferences (Mac OS) and select the General Category in 
the Preferences dialog box.

2. Make sure both Scale Content options (Align Top Left 
and Include Locked And Hidden Layers) are selected 
(Figure 2).

The second option ensures that when Adaptive Scaling is 
enabled, the content in locked and hidden layers will 
scale along with the rest of the document.

3. Click OK to confirm the document preferences.

4. In the Properties section of the Properties panel, click the 
Edit Document Properties button (Figure 3). 

The Document Settings dialog box appears (Figure 4).

Notice the current size of the document. In this example 
it’s 480 x 800, the default size for AIR for Android apps. 
If you were adapting this design to match an iOS device 
screen, you’d change the document size to 640 x 960, the 
default dimensions for AIR for iOS apps.  

5. Change the document dimensions to 640 (width) and 960 
(height), or other dimensions that match your target 
screen.

6. Dimensions represent the size of the Stage. 

When you change the Stage dimensions, you also have 
the option to turn on Adaptive Scaling options. These 
include:

• Adjust 3D Perspective Angle: Adjusts the position 
and orientation of 3D objects on the Stage to 
maintain their appearance relative to the edges of the 
Stage.

• Scale Content With Stage: Automatically scales the 
contents of the Stage relative to the change in Stage 
size.

7. Select Scale Content With Stage.

Note: If your document includes 3D objects, you also 
want to select the option to adjust the 3D perspective 
angle.

8. Click OK.

The Stage area changes size. Flash Professional does its 
best to scale the content to match the Stage. Depending 
on how accurate the scaling, you may need to manually 
fine-tune the size of some content objects. 

In this example, Flash Professional came close to 
matching the content to the Stage, but some minor 
adjustments are needed (Figure 5).

Figure 2 Preferences dialog box, Scale Content 
options 

Figure 3 Properties panel, Properties section

Figure 4 Document Settings dialog box 

Figure 5 Resized document and content 

Edit Document Properties button
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9. Select Edit > Select All.

This selects all content objects in the current frame. You 
can resize the mixed selection as a single object by using 
the Free Transform tool or by changing the Position And 
Size values in the Properties panel (Figure 6).

10. Enter new dimensions for the mixed selection by 
changing the width (W:) and height (H:) values in the 
Position And Size section of the Properties panel. 

The group scales together to match the new dimensions 
(Figure 7).

Note: You may need to resize other content objects that 
appear in the timeline. Resizing the content can also 
distort your artwork when the new document dimensions 
have a different aspect ratio (height to width) than the 
original document.

Figure 6 Properties panel, Position And Size 

Figure 7 Manually scaled content 
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To copy layers and content from one document to another:

1. Open a completed Flash Professional document that you 
want to adapt to another screen.

2. Open a new blank document and specify settings to 
match the new target device. 

3. Use the document tab in the Flash Professional 
workspace to switch back to the file that contains your 
finished content (Figure 8).

4. Select the top layer in the Timeline panel.

5. Shift-click the bottom layer in the Timeline panel.

This selects all layers and content in the timeline 
(Figure 9). 

Note: You can also select individual layers or multiple 
noncontiguous layers by holding down Ctrl (Windows) 
or Command (Mac OS) as you select.

6. Right-click (Windows) or Control-click (Mac OS) and 
select Copy Layers from the context menu.

7. Use the document tab to change to your new blank 
document.

The new document includes one empty layer named 
Layer 1.

8. Right-click (Windows) or Control-click (Mac OS) 
Layer 1 in the Timeline panel and select Paste Layers.

The layers are added to the new document’s timeline 
directly above Layer 1 (Figure 10).

9. Select Window > Library to open the Library panel in the 
new document.

The new document’s library includes every object from 
the source file (Figure 11).

Figure 8 Document tabs

Figure 9 Timeline panel, source document

Figure 10 Timeline panel, new document

Figure 11 Library panel, new document
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Using ActionScript code to scale content to multiple screens

At times you need your content to scale automatically to fit each end user’s screen. For example, a mobile app needs 
to rotate and scale when users turn their tablets from portrait to landscape orientation. You may also be developing 
web content that you want mobile users to access from any device. This content needs to scale to adapt to each user’s 
screen size.

One way to accomplish this is to use ActionScript code that controls content scaling. In this guide you create a new 
document and use ActionScript code to control document scaling. To test the ActionScript code that controls object 
position and scaling, you create content objects and give them instance names that match the references to these 
objects in the sample ActionScript code.   

To use ActionScript to scale content to multiple screens:

1. Start Flash Professional and open a new AIR For 
Android document with white as the document 
background color.

2. Select View > Magnification > Fit In Window so you can 
see the entire Stage. 

3. Create the following sample objects in the application:

Note: You can import artwork or use the drawing tools to 
create the sample content objects (Figure 12).

• Background layer: Artwork that fills or extends 
beyond the Stage. For this example, we used the 
Deco tool to create a Vine Fill pattern. Convert the 
background artwork to a movie clip symbol and 
name the instance back_art. 

• Text layer: TLF text that fills the lower quarter of the 
Stage and is the same width as the Stage. Name the 
TLF text instance main_txt.

• Image layer: Add an image or draw a simple shape. 
Position the shape above the text. Convert it to a 
movie clip symbol and name the instance 
main_image.

• Title layer: Use the text tool to create a sample title. 
Position it near the top of the screen. Convert the 
title to a movie clip symbol and name the instance 
app_title.

The Timeline panel now includes the layers and sample 
content to add the position and scale ActionScript code 
(Figure 13). 

Before you add the code, however, you need to test the 
movie to see how it scales.

Figure 12 Background image 

Figure 13 Timeline panel 
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4. Make sure nothing is selected on the Stage. 

5. In the Properties panel, change Publish Target from AIR 
3.2 For Android to a Flash Player version—for example 
Flash Player 11.2 (Figure 14).

Changing to Flash Player will let you test in Flash 
Professional and resize the preview window.

6. Select Control > Test Movie > In Flash Professional.

7. Drag the edges of the preview window to see what 
happens to the content when the window or screen size is 
different from the original dimensions of the application. 

Because the content does not scale automatically along 
with the screen size, it gets cut off (Figure 15). 

8. Close the preview window.

9. Insert a new layer in the Timeline panel and name it 
Actions.

10. Select Window > Actions to open the Actions panel.

Figure 14 Properties panel, Publish settings 

Figure 15 Sizing the preview window 
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11. Enter or copy and paste the following code into the Action panel to prevent the Stage from scaling automatically:

//This code is to prevent the stage from scaling until you tell it to.

stage.scaleMode = StageScaleMode.NO_SCALE;

stage.align = StageAlign.TOP_LEFT;

12. Enter or copy and paste the following Event Listener to listen for when the window is resized and call the 
setPosition function to size and position objects on the Stage:

stage.addEventListener(Event.RESIZE, resizeLayout);

function resizeLayout(e:Event):void

{

setPosition();

}

13. Enter or copy and paste the following code for the setPosition function that scales and positions the objects in the 
movie based on the size and position of the Stage: 

function setPosition():void

{

//Position elements according to the stage.stageWidth and stage.stageHeight

   main_txt.autoSize = TextFieldAutoSize.LEFT;

   main_txt.width = stage.stageWidth + 10;

   main_txt.y = stage.stageHeight - main_txt.height;

   app_title.x = stage.stageWidth / 2;

   main_image.x = app_title.x;

   main_image.y = main_txt.y - main_image.height;

   back_art.height = stage.stageHeight;

   back_art.width = back_art.height;

   if (stage.stageWidth > stage.stageHeight){

      back_art.width = stage.stageWidth;

      back_art.height = back_art.width

   }

   back_art.x = stage.stageWidth/2;

   back_art.y = stage.stageHeight/2;

}
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14. Close the Actions panel.

15. Select Control > Test Movie > In Flash Professional.

16. Drag the edges of the preview window to see what 
happens to the content when the window or screen size is 
different from the original dimensions of the application. 

The content scales automatically to match the screen size 
and objects are repositioned as well as possible to match 
the intended design (Figure 16). 

17. Close the preview window.

18. In the Properties panel, change Publish Target back to 
AIR 3.2 For Android and click the Edit Application 
Settings button (Figure 17).

The AIR For Android Settings dialog box appears.

19. On the General tab, select Auto Orientation (Figure 18).

The app will automatically alternate between portrait and 
landscape view when users turn their mobile devices.

20. Select the Deployment tab and select Emulator Release 
(Figure 19).

This tells Flash Professional that you are testing the 
application instead of publishing the app for installation 
on a device.

21. Click OK to save your changes and close the dialog box.

Figure 16 Sizing the preview window 

Figure 17 Properties panel

Figure 18 AIR For Android Settings dialog box, 
General tab

Figure 19 AIR For Android Settings dialog box, 
Deployment tab

Edit Application Settings button
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22. In the Properties panel, click the Edit ActionScript 
Settings button (Figure 20).

The Advanced ActionScript 3.0 Settings dialog box 
appears (Figure 21).

23. Select the Library Path tab.

24. Open the Default Linkage menu in the Runtime Shared 
Library Settings section of the dialog box and choose 
Merged Into Code (Figure 21).

25. Click OK.

This embeds any shared libraries such as TLF Text 
libraries used to format text and prevents Flash 
Professional errors when you test or publish the mobile 
application. 

Figure 20 Properties panel

Figure 21 Advanced ActionScript 3.0 Settings 
dialog box

Edit ActionScript Settings button
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26. Select Control > Test Movie > In AIR Debug Launcher 
(Mobile).

The application opens and the Device preview window 
appears (Figure 22). It shows how the app appears on an 
Android device in the vertical (portrait) position.

27. (Windows) Open the Device menu and select Rotate 
Right (Figure 23).

The app rotates to horizontal (landscape) orientation and 
its contents scale and reposition to fit the screen 
(Figure 24).

28. (Mac OS) Make sure the Accelerometer section is 
visible. Drag the Z axis slider to either the left or right 
until the number of degrees is –90 or 90, respectively. 

You can also select the degree value for the Z axis and 
enter –90 or 90.

The device rotates 90 degrees and the app appears in 
horizontal (landscape) orientation. Its contents scale and 
reposition to fit the screen.

Figure 22 Device preview window

Figure 23 Device menu

Figure 24 Horizontal (landscape) orientation
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