
Adobe Premiere Pro Guide
How to build text and objects in the Titler
You can use the Titler in Adobe Premiere Pro to create text and geometric objects. There are three methods for 
creating text, each capable of producing either horizontal or vertical text:

• Point text: Use the Type tool to create point text. Specify an insertion point to begin typing. As you type, a 
bounding box expands to accommodate the additional text. The text runs on one line until you press Enter 
(Windows) or Return (Mac OS) or select Word Wrap from the Title menu in the main menu bar. Later, changing 
the shape and size of the bounding box correspondingly changes the shape and size of the text.

• Paragraph text: Use the Area Type tool to set the size and shape of your text box and then type text. Paragraph 
text wraps automatically within the borders of the box. Changing the box size displays more or less text but does 
not change the shape or size of the text.

• Path text: Use the Path Type tool to build a path for your text to follow by clicking points in the Titler main panel 
to create curves and adjusting the shape and direction of those curves. Then type text along that path.

We recommend you complete the “Understanding the Titler” guide before working on the tasks in this guide. That 
guide explains all of the Titler panels and many of its properties in detail as preparation for this guide.

Creating point text

Use the Type tool to create point text.

To create point text:

1. Start Adobe Premiere Pro, start a new project, and import 
a video clip.

2. Drag the clip to the Video 1 (V1) track in the Timeline 
panel.

3. Select File > New > Title to display the New Title dialog 
box.

4. Type a title name in the Name box and click OK.

The Titler appears.

5. In the Title Styles panel (Figure 1), click a style that suits 
you.

Note: Later in this task you will change the style 
characteristics, which you can save as a customized style.

6. In the Titler Tools panel, click the Type tool (Figure 2), 
click anywhere in the Titler main panel, and type some 
text.

Note: The Type tool creates point text. Point text does 
not wrap. It continues off the screen to the right.

7. To begin a new line of text, press Enter (Windows) or 
Return (Mac OS).

8. To make the point text wrap when it reaches the title-safe 
margin, choose Title > Word Wrap from the main menu.

Note: You can turn off the title-safe margin and action-
safe margin by opening the Titler menu (or selecting Title 
> View from the main menu) and then selecting either 
Safe Title Margin or Safe Action Margin.

Figure 1 Title Styles panel

Figure 2 Titler Tools panel
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9. In the Titler tools panel, click the Selection tool 
(Figure 2) and click the title text to select it.

Handles appear on the text bounding box (Figure 3).

10. Drag the corners and edges of the text bounding box and 
note how the text changes size and shape.

Note: In addition to dragging bounding-box handles to 
change text size, you can also change the values of Width 
and Height in the Transform area at the top of the Title 
Properties panel.

11. Hover the pointer just outside any handle of the text 
bounding box until you see the curved-line rotation 
pointer. Then drag the bounding box to rotate it out of its 
horizontal orientation (Figure 4).

Note: You can also do this action by using the Rotation 
tool (Figure 2) or by changing the value of Rotation in 
the Transform area of the Title Properties panel.

12. Edit the text by double-clicking with the Selection tool 
anywhere in the text and typing.

You can drag to select text you want to remove or 
replace.

13. In the upper-right corner of the Titler main panel, click 
the Show Background Video button (Figure 5) to hide or 
show the background video behind the title (Figure 6).

Note: Clicking this button toggles the background video 
on or off. Make sure in this instance, the background 
video is toggled on.   

14. Drag the Background Video Timecode (located below the 
Show Background Video button) to change to a different 
video frame.

Note: You can use the Show Background Video feature 
to help you position text or geometric objects over video 
clips.

15. Delete the text by clicking the Selection tool, clicking the 
text in the Titler main panel (the bounding box and its 
handles appear around the text), and then pressing Delete.

16. Click the Show Background Video button to switch off 
the display.

17. Select the Vertical Type tool, click in the Titler main 
panel, and start typing (Figure 7).

Pressing Enter (Windows) or Return (Mac OS) places the 
second vertical column to the left of the first column. 
This is the default behavior because vertical text in 
parallel columns is principally used for Japanese text.

18. Close the Titler.

Figure 3 Point text with bounding box

Figure 4 Rotation pointer

Figure 5 Show Background Video button

Figure 6 Titler with video background showing

Figure 7 Vertical point text
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Creating paragraph text

Use the Area Type tool to set the size and shape of your text box and then type your text.

To create paragraph text:

1. In the main menu bar, select File > New > Title.

2. Type a title name in the Name box and click OK.

3. In the Titler, click the Area Type tool (Figure 2).

The Area Type tool creates paragraph text.

Note: At any point in this or the following tasks, you can 
change the text style by clicking on a style in the Title 
Styles panel.

4. In the Titler main panel, drag to create a text bounding 
box that nearly fills the title-safe margin.

5. Start typing. Type enough characters to attempt to go 
beyond the right edge of the bounding box.

Paragraph text wraps at the bounding box borders and 
does not expand the bounding box you defined. To go 
down a line before hitting the right edge of the box, press 
Enter (Windows) or Return (Mac OS) (Figure 8).

6. Click the Selection tool and drag the edges of the 
bounding box to change its size and shape.

Note: The text does not change size. Instead it adjusts its 
position on the bounding box baselines. If you make the 
box too small for all your text, the extra text scrolls below 
the bounding box’s bottom edge and a little plus (+) 
appears near the lower-right corner outside the bounding 
box (Figure 9).

7. Close the Titler.

Figure 8 Paragraph text

Figure 9 Marker indicating additional paragraph 
text is near the bounding box
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Creating text on a path

The Path Text tool is both elegant and tricky. You can use it to build paths that are simple or complex, straight or 
curved, for your text to follow.

If you’ve worked with the Pen tool in Adobe Photoshop CC, you know how to use the Path Text tool. Basically, you 
define a path by clicking a number of locations in the Titler main panel and dragging handles at each point to define 
the curves.

To put text on a path:

1. In the main menu bar, select File > New > Title.

2. Type a title name in the Name box and click OK.

3. In the Titler, select the Path Type tool in the Titler Tools 
panel (Figure 2).

4. Drag diagonally anywhere in the Titler main panel.

That creates an anchor point with handles (Figure 10). 
You use those handles to define the curve’s 
characteristics. If you click without dragging the pointer, 
you won’t add handles. Adding them later is tricky.

5. Drag somewhere else to create another anchor point with 
handles.

The Titler automatically creates a curved path between 
the anchor points (Figure 11).

6. Add at least two more anchor points.

Each new point added outside the confines of the current 
bounding box expands the bounding box dimensions.

7. Delete any point by selecting the Delete Anchor Point 
tool (Figure 12) and clicking an anchor point.

Figure 10 Path text anchor point (center) and 
handles

Figure 11 Path text anchor points and bounding 
box

Figure 12 Path Type tools
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8. Click the Pen tool, hover the pointer over any handle (the 
pointer changes to a black arrow), and drag the handle 
(Figure 13).

Make the path longer, shorter, or just move the path 
around to see how this tool works.

9. Hover the Pen tool over an anchor point (the pointer 
changes to the same black arrow that appears over 
handles), and drag the anchor point to a new location to 
change the path’s shape.

10. Click the Path Type tool again and then click anywhere 
inside the newly created bounding box, but not on the 
path or anchor points.

A blinking insertion point appears at the beginning of the 
curved line.

11. Type some text.

Your text follows the path (Figure 14).

Note: If the text is too large to fit the path, use the Font 
Size adjustment in the Properties panel to reduce the font 
size.

Figure 13 Pen tool on a handle

Figure 14 Text on a path 

Creating shapes

If you’ve created shapes in graphics-editing software such as Adobe Photoshop or Adobe Illustrator, you know how 
to create geometric objects in the Adobe Premiere Pro Titler: you simply select from the various drawing tools in the 
Titler Tools panel and drag to draw the shape.

To create shapes:

1. Continue where you left off in the previous task (with the 
Titler open).

2. In the Main menu bar, select Title > New Title > Based 
On Current Title, or open a new title (File > New > Title).

The New Title dialog box appears.

3. Type a title name in the Name box and click OK.

4. In the Titler, click the Selection tool, select the text in the 
Titler main panel, and press Delete to create a clean slate.

5. Select the Rectangle tool from the Titler Tools panel 
(Figure 15) and drag in the Titler main panel to create a 
rectangle (Figure 16).

The rectangle has the characteristics of the style you 
choose in the Title Properties panel. In this example, the 
rectangle has white solid fill and a shadow.

Figure 15 Drawing tools

Figure 16 Rectangle 
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6. In the Titler main panel, make a square by dragging with 
the Rectangle tool while holding down the Shift key to 
constrain the shape’s aspect ratio.

Note: Using the Shift modifier key creates shapes with 
symmetrical properties: circles, squares, equilateral 
triangles, and arcs with right angles. To maintain the 
aspect ratio while resizing a shape you've already made, 
hold the Shift key before making the change.

7. Click the Selection tool, marquee-select the two objects 
in the Titler main panel, and press Delete to make a clean 
slate.

8. Select the Rounded Corner Rectangle tool and Alt-drag 
(Windows) or Option-drag (Mac OS) to draw from the 
center of the shape (Figure 17).

Using the modifier key makes the center remain in the 
spot where you first clicked. The object changes shape 
and size around that point as you drag the pointer.

9. Select the Clipped Corner Rectangle tool. Hold down the 
Shift key and Alt-drag (Windows) or Option-drag (Mac 
OS) to constrain the aspect ratio and draw from the center 
(Figure 17).

10. Select the Arc tool and drag diagonally across the corner 
points to flip the shape diagonally as you draw 
(Figure 17).

11. Click the Wedge tool and drag across, up, or down to flip 
the shape horizontally or vertically as you draw 
(Figure 17).

Note: To flip a shape after you’ve drawn it, use the 
Selection tool to drag a corner handle in the direction you 
want it to flip.

12. Use the Selection tool to marquee-select the objects you 
just created and press Delete to make another clean slate.

13. Select the Line tool and drag to create a single line.

Note: To connect another segment to the line you just 
drew, attempt to click on the end point of the line. It’s an 
imprecise process. As shown in the next few steps, the 
Pen tool connects lines more elegantly.

14. Select the Pen tool and click anywhere in the Titler main 
panel to create an anchor point that will become the end 
point of a line segment (don’t drag to create handles).

Figure 17 Rounded rectangle, cropped-corner 
rectangle, arc, and wedge 
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15. Click again in the Titler main panel where you want the 
segment to end. (Shift-click to constrain the segment’s 
angle to multiples of 45°.)

This creates another anchor point, and a line segment 
appears between the two points.

16. Continue clicking the Pen tool to create additional 
straight segments.

17. Complete the path by doing one of the following:

• To close the path, hover the Pen tool over the initial 
anchor point until a circle appears next to the Pen 
tool pointer (Figure 18). Click to make the 
connection.

• To leave the path open, Ctrl-click (Windows) or 
Option-click (Mac OS) in the Titler main panel away 
from all objects and their bounding boxes.

18. Close the Titler.

Figure 18 Closing a path

Adding Closed Captions

You can import closed caption files or create them from scratch in Adobe Premiere Pro. Once you’ve added captions 
to a sequence, you can edit them. For example, you can edit the caption’s text, style, color, background and position 
in the Timeline. When your project is complete, you can export your movie along with a sidecar caption file or embed 
the closed captions inside a QuickTime (MOV) file. To complete the steps in this activity, you will need a movie clip 
and a closed caption (SCC) file. Closed caption files are generated by using specialized software, such as 
MacCaption, MovieCaptioner, or CaptionMaker for Windows. 

To add an SCC closed caption file to a sequence:

1. Begin a new Adobe Premiere Pro project and create a 
sequence that matches your source footage.

2. Import your video clip and its associated closed caption 
file.

Note: In this example, we are using a Scenarist closed 
caption file with the .scc file extenstion. The source video 
clip was opened in a closed caption application and used 
to generate the closed captions. 

3. Drag the video clip to Video track 1 (V1) in the Timeline.

4. Drag the closed caption clip to Video track 2 (V2) in the 
Timeline (above the video clip) (Figure 19).

The captions appear on the closed caption clip in the 
Timeline. You may need to expand the V2 track to see the 
captions in the Timeline.

5. In the Program Monitor, open the panel menu and select 
Closed Cationing Display > Enable.

6. Play the sequence. 

The captions display in the Program Monitor 
(Figure 20).

Figure 19 Video and closed caption clips in the 
Timeline

Figure 20 Closed Captions in the Program Monitor 
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To edit closed captions:

1. Select the closed caption clip in the Timeline panel.

2. Open the Captions panel. If the Captions panel tab is 
hidden, you can select Window > Captions to locate and 
open the panel. 

Using the Captions panel, you can edit caption text, 
format the text, change the background color, or change 
the timing of each caption by changing the In and Out 
times (Figure 21).

You can also click Add Caption (plus sign) and Delete 
Caption (minus sign) to add and remove captions. 

Note: If you expand the Captions panel, you can also 
access the X and Y position controls used to move the 
position of captions on screen.

3. Use the Caption panel to edit or position your captions as 
needed. Figure 21 Captions panel

To create new closed caption text from scratch:

1. Open the Project panel.

2. Click the New Item button (Figure 22) and select Closed 
Captions. 

The New Closed Captions dialog box appears. 

3. Click OK twice to accept the default settings for the new 
closed caption clip.

A new closed captions clip appears in the project panel. 

4. Drag the closed captions clip to the Timeline and place it 
in a video track above the video you want to caption.

5. Select the closed captions clip in the Timeline and then 
open the Captions panel.

Use the Captions panel to create your new captions 
(Figure 23).

Figure 22 Project panel

Figure 23 Captions panel

New Item button
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To export a movie with closed captions:

1. Open the Project panel and select the completed sequence 
you want to export.

Note: Most export options allow you to export your 
closed captions as a separate sidecar caption file that is 
linked to the video. If you export the video as a 
QuickTime (MOV) file, you have the option to embed the 
captions in the video. 

2. Select File > Export > Media. 

The Export Settings dialog box appears. 

3. Open the Format menu and select H.264.

4. Select the Captions tab in the Export Settings dialog box. 

5. Open the Export Options menu in the Captions panel. 

Most video formts require that you export closed 
captions as a separate sidecar file (Figure 24). If you 
want to embed your captions within the video file, you 
must export the video as a QuickTim movie with the 
.mov file name extension.

6. Open the Format menu and select QuickTime.

7. Open the Presets menu and select a preset to match your 
source video.

8. Click the Output Name link to open the Save As dialog 
box.

9. Enter a name and select a location for the new movie, 
then click Save.

10. In the Captions panel, open the Export Options menu and 
choose Embed In Output File (Figure 25).

11. Click Export.

The new QuickTime movie is created in the folder you 
specified. When you play the movie using the QuickTime 
player, you can select View > Show Closed Caption to 
turn captions on (Figure 26).

The closed captions appear over the video (Figure 27).

Figure 24 Caption Export Options for H.264 video 

Figure 25 Captions Export Options for QuickTime 
video

Figure 26 QuickTime player View menu

Figure 27 Embedded captions in a QuickTime 
movie
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