
Adobe Illustrator
How to modify and transform graphics
Adobe Illustrator offers many options to modify and transform graphics. This guide introduces many common 
transformation tools, such as:

• Scaling, shearing (Figure 1), rotating, and flipping objects

• Distortion

• The Blend tool used to merge two objects into one to create one graphic

• A wide variety of effects, such as the Drop Shadow, Blur, and Sketch

Figure 1 Shearing an object

Transforming graphics

Transforming encompasses moving, rotating, reflecting, scaling, and shearing objects. You can transform objects by 
using the Transform panel, Object > Transform commands, and specialized tools. You can also perform many types 
of transformations by dragging the bounding box for a selection.

Sometimes you may want to repeat the same transformation several times, especially when you are copying objects. 
The Transform Again command in the Object menu lets you repeat a move, scale, rotate, reflect, or shear operation as 
many times as you want, until you perform a different transform operation. You can use the Info panel to view the 
current dimensions and position of your selection as you transform it.

Transform panel overview

The Transform panel (Window > Transform) displays information about the location, size, and orientation of one or 
more selected objects (Figure 2). By typing new values, you can modify the selected objects, their pattern fills, or 
both. You can also change the transformation reference point and lock the object’s proportions.

Figure 2 Transform panel

Reference point locator

Panel menu

Lock proportions icon
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All values in the panel refer to the bounding boxes of the objects except for the X and Y values, which refer to the 
selected reference point. To pixel-align individual objects to the pixel grid, check the Align to Pixel Grid check box.

Note: The reference point locator in the Transform panel specifies an object’s reference point only when you 
transform the object by changing the values in the panel. Other methods of transforming (such as using the Scale tool) 
use the object’s center point or the pointer location as the reference point.

Transform an object’s patterns

When you move, rotate, reflect (flip), scale, or shear an object that is filled with a pattern, you can transform just the 
object, just the pattern, or both the object and pattern. Once you transform an object’s fill pattern, all patterns you 
subsequently apply to that object are transformed the same way. 

• To specify how you want to transform patterns when using the Transform panel, select an option from the 
panel menu (Figure 3): Transform Object Only, Transform Pattern Only, or Transform Both.

• To specify how you want to transform patterns when using a transform command, set the Objects and 
Patterns options in the corresponding dialog box. For example, select Patterns and deselect Objects if you 
want to transform the pattern but not the object.

• To transform patterns but not objects when using a Transform tool, hold down the tilde key (~) while 
dragging. The borders of the object appear to be transformed, but when you release the mouse button, the 
borders snap back to their original configuration, leaving only the pattern transformed.

• To prevent patterns from transforming when you’re using Transform tools, choose Edit > Preferences > 
General (Windows) or Illustrator > Preferences > General (Mac OS) and deselect Transform Pattern Tiles.

• To return an object’s fill pattern to its original state, fill the object with a solid color, and then reselect the 
desired pattern.

Figure 3 Transform panel menu

Transform by using the bounding box

When you select one or more objects with the Selection tool, a bounding box appears around them. Use the bounding 
box to easily move, rotate, duplicate, and scale objects by dragging the object or a handle (one of the hollow squares 
along the bounding box) (Figure 4). 

Figure 4 Selected objects before (left) compared to after (right) scaling by using the bounding box
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• To show the bounding box, choose View > Show Bounding Box.

• To hide the bounding box, choose View > Hide Bounding Box.

• To reorient the bounding box after you rotate it, choose Object > Transform > Reset Bounding Box.

Move objects

You can move objects by dragging them with specific tools, by using the arrow keys on the keyboard, or by entering 
precise values in the Control panel (Figure 5).

Figure 5 Control panel

You can use snapping to help you position objects as you move them. For example, you can snap the pointer to guides 
and anchor points and snap object boundaries to gridlines. You can also use the Align (Window > Align) panel to 
position objects in relation to each other (Figure 6).

Figure 6 Aligning objects with the panel

You can then use the Shift key to constrain the movement of one or more objects so they move in a precise horizontal, 
vertical, or diagonal direction relative to the current orientation of the x and y axes. You can also use the Shift key to 
rotate objects in multiples of 45° (Figure 7).

Figure 7 Hold down Shift while dragging or drawing to limit movement to the nearest 45° angle.

Scale objects

Scaling an object enlarges or reduces it horizontally (along the x axis), vertically (along the y axis), or both. Objects 
scale relative to a reference point that varies depending on the scaling method you choose. You can change the default 
reference point for most scaling methods, and you can also lock the proportions of an object.

Note: After you scale an object, Illustrator does not retain the original size of the object in memory. Therefore, you 
cannot resume the original size of the object. However, you can see the resolution of the object in the Document Info 
panel and decide on the scale at which you want to resize the object, while retaining the object’s resolution.
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By default, strokes and effects are not scaled along with objects. To scale strokes and effects, choose Edit > 
Preferences > General (Windows) or Illustrator > Preferences > General (Mac OS), and select Scale Strokes & 
Effects (Figure 8). If you want to choose whether to scale strokes and effects on a case-by-case basis, use the 
Transform panel or the Scale command to scale objects.

Figure 8 The Scale Strokes & Effects option scales the object, the drop shadow effect, and the stroke (left); only the 
object scales when this option is off (right).

How to scale objects with the Scale tool:

1. Select one or more objects.

2. Select the Scale tool (Figure 9).

3. Do any of the following:

• To scale relative to the object’s center point, drag 
anywhere in the document window until the object is 
the desired size (Figure 10).

• To scale relative to a different reference point, click 
where you want the reference point to be in the 
document window, move the pointer away from the 
reference point, and then drag until the object is the 
desired size.

• To maintain the object’s proportions as it scales, hold 
down Shift as you drag diagonally. 

Note: While using the Scale tool with the Shift key, 
start dragging at an angle of 45° horizontally or 
vertically.

• To scale the object along a single axis, hold down 
Shift as you drag vertically or horizontally.

Figure 9 Tools panel

Figure 10 Drag to resize, using Scale tool

How to scale objects with the bounding box:

1. Select one or more objects.

2. Select the Selection tool.

3. Drag a bounding box handle until the object is the desired 
size (Figure 11).

Objects scale relative to the opposite handle of the 
bounding box.

Figure 11 Drag to resize, using Selection tool
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4. Do any of the following to control the scaling behavior:

• To maintain the object’s proportions, hold down 
Shift as you drag.

• To scale relative to the object’s center point, hold 
down Alt (Windows) or Option (Mac OS) as you 
drag.

How to scale objects to a specific dimension:

1. Select one or more objects.

2. In the Transform panel, enter a new value in the Width 
(W) or Height (H) box, or both (Figure 12).

To control the scaling behavior, do any of the following 
before you enter a value.

• To maintain the objects’ proportions, click the lock 
proportions button.

• To change the reference point for scaling, click a 
white square on the reference point locator.

• To scale stroked paths and any size-related effects 
along with the object, select Scale Strokes & Effects 
from the panel menu.

Figure 12 Scale using the Transform panel

Shear objects

Shearing an object slants, or skews, the object along the horizontal or vertical axis, or a specified angle that’s relative 
to a specified axis. Objects shear relative to a reference point that varies depending on the shearing method you 
choose and can be changed for most shearing methods (Figure 13). You can lock one dimension of an object as you 
shear it, and you can shear one object or multiple objects simultaneously.

Figure 13 Shearing relative to the center (left) compared to shearing relative to a user-defined reference point (right)

How to shear objects with the Shear tool:

1. Select one or more objects.

2. Select the Shear tool (Figure 14).

Figure 14 Tools panel
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3. Do one of the following:

• To shear relative to the object’s center, drag 
anywhere in the document window (Figure 15).

• To shear relative to a different reference point, click 
anywhere in the document window to move the 
reference point, move the pointer away from the 
reference point, and then drag until the object is at 
the desired slant.

• To shear along the object’s vertical axis, drag 
anywhere in the document window in an up or down 
direction. To constrain the object to its original 
width, hold down Shift.

• To shear along the object’s horizontal axis, drag 
anywhere in the document window in a left or right 
direction. To constrain the object to its original 
height, hold down Shift.

Figure 15 Drag to shear an object

How to shear objects with the Transform panel:

1. Select one or more objects.

2. In the Transform panel, enter a value in the Shear box 
(Figure 16).

The shear is applied (Figure 17).

To change the reference point, click a white square on the 
reference point locator before you enter the value.

Figure 16 Shear using the Transform panel

Figure 17 Shear applied

Rotate objects

Rotating an object turns it around a fixed point that you designate. The default reference point is the object’s center 
point. If you have multiple objects in a selection, the objects will rotate around a single reference point, which is the 
center point of the selection or bounding box by default. 
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To rotate each object around its own center point, use the Transform Each command (Figure 18). You can control the 
exact angle of rotation with the Rotate command.

Figure 18 Results of Rotate tool (left) compared to Transform Each command (right)

How to rotate an object using the bounding box:

1. Select one or more objects.

2. With the Selection tool, move the pointer outside the 
bounding box and near a bounding box handle so that the 
pointer changes to the rotate icon (Figure 19), and then 
drag.

Figure 19 Rotate using the bounding box

How to rotate an object with the Rotate tool:

1. Select one or more objects.

2. Select the Rotate tool (Figure 20)

3. Do any of the following:

• To rotate the object around its center point, drag in a 
circular motion anywhere in the document window 
(Figure 21).

• To rotate the object around a different reference 
point, click once anywhere in the document window 
to reposition the reference point. Then move the 
pointer away from the reference point and drag in a 
circular motion. 

• To rotate a copy of the object instead of the object 
itself, hold down Alt (Windows) or Option (Mac OS) 
after you start to drag. 

Figure 20 Tools panel

Figure 21 Drag to rotate an object
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Reflect or flip objects

Reflecting an object flips the object across an invisible axis that you specify (Figure 22). You can reflect objects by 
using the Free Transform tool, the Reflect tool, or the Reflect command. If you want to specify an axis from which to 
reflect, use the Reflect tool.

Figure 22 Click to set one point of the axis (left), then click again to set the other axis point and reflect the object 
across the axis (right).

How to reflect an object with the Free Transform tool:

1. Select the object to reflect. 

2. Select the Free Transform tool and confirm Free 
Transform is selected in the options pane (Figure 23). 

The Free Transform tool provides other options to 
constrain proportions, to distort perspective, and to free 
distort the selected object.

3. Do one of the following:

• Drag a handle of the bounding box past the opposite 
edge or handle until the object is at the desired level 
of reflection (Figure 24).

• To maintain the object’s proportions, hold down 
Shift while dragging a corner handle past the 
opposite handle. Figure 23 Tools panel with Free Transform pane

Figure 24 Drag to reflect

How to reflect an object with the Reflect tool:

1. Select the object. 

2. Select the Reflect tool (Figure 25).

3. To draw the invisible axis across which you want the 
object to reflect, click anywhere in the document window 
to set one point of the axis. The pointer changes to an 
arrowhead.

Figure 25 Tools panel

Free Transform
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4. Position the pointer at another point to define the 
invisible axis, and do one of the following:

• Click to set the second point of the invisible axis. 
When you click, the selected object flips over the 
defined axis (Figure 26).

• To reflect a copy of the object, hold down Alt 
(Windows) or Option (Mac OS) and click to set the 
second point of the invisible axis.

• Adjust the axis of reflection by dragging instead of 
clicking. Shift-drag to constrain the angle by 45°. As 
you drag, the invisible axis of reflection rotates 
around the point you clicked in step 3 and an outline 
of the object appears reflected. When the outline is in 
the desired position, release the mouse button. 

Figure 26 Click to reflect an object

Distorting graphics

You can distort objects by using the Free Transform tool or a Liquify tool. Use the Free Transform tool when you 
want to distort freely; use a Liquify tool if you want to take advantage of specific preset distortions such as twirls, 
puckers, or wrinkles. The following tools can be used for reshaping and distorting objects:

You cannot use Liquify tools on linked files or objects that contain text, graphs, or symbols.

The Width tool allows you 
to create a stroke with vari-
able width. 

The Warp tool molds 
objects with the movement 
of the cursor (like molding 
clay, for example).

The Twirl tool creates 
swirling distortions within 
an object. 

The Pucker tool deflates an 
object by moving control 
points toward the cursor.

The Bloat tool inflates an 
object by moving control 
points away from the cur-
sor.

The Scallop tool adds ran-
dom curved details to the 
outline of an object. 

The Crystallize tool adds 
random spiked details to the 
outline of an object. 

The Wrinkle tool adds 
wrinkle-like details to the 
outline of an object.
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How to distort objects with the Free Transform tool:

1. Select one or more objects.

2. Select the Free Transform tool. 

3. Choose Free Distort in the options pane (Figure 27). 

The Free Transform tool provides other options to 
constrain proportions, to distort perspective, and to free 
distort the selected object.

4. Start dragging a corner handle on the bounding box (not a 
side handle) (Figure 28) and release when you‘ve 
achieved the desired level of distortion.

Figure 27 Tools panel with Free Transform pane

Figure 28 Drag to free distort

How to distort objects using a Liquify tool:

1. Select a Liquify tool (Figure 29). 

There are many to choose from, including the Width tool, 
Warp tool, Twirl tool and more. This example will 
demonstrate the Bloat tool.

Figure 29 Tools panel

Free Distort
How to modify and transform graphics © 2013 Adobe Systems Incorporated

This document requires Adobe Illustrator CC, June 2013. Technical instructions may differ depending on your version.



Adobe Illustrator
2. Click or drag over the objects you want to distort 
(Figure 30).

The object is distorted (Figure 31).

3. (Optional) To isolate the distortion to specific objects, 
select the objects before using the tool.

4. (Optional) To change the size of the tool cursor and set 
other tool options, double-click the Liquify tool and 
specify any of the following in the dialog box 
(Figure 32):

• Width and Height Controls the size of the tool cursor.

• Angle Controls the orientation of the tool cursor.

• Intensity Specifies the rate of change for the 
distortion. Higher values equal faster changes. 

• Use Pressure Pen Uses the input from a tablet or pen 
instead of the Intensity value. If you don’t have a 
pressure-sensitive tablet attached, this option is 
dimmed.

• Complexity (Scallop, Crystallize, and Wrinkle tools) 
Specifies how closely the results of the particular 
brush are spaced on the object’s outline. This is 
closely tied with the Detail value. 

• Detail Specifies the spacing between points 
introduced into the object’s outline (higher values 
space points closer together).

• Simplify (Warp, Twirl, Pucker, and Bloat tools) 
Specifies how much you want to reduce the 
superfluous points that do not measurably affect the 
overall appearance of the shape.

• Twirl Rate (Twirl tool only) Specifies the rate at 
which the twirl is applied. Enter a value between      
–180° and 180°. Negative values twirl the object 
clockwise and positive values twirl counter-
clockwise. The object twirls faster with values that 
are closer to either –180° or 180°. To twirl slowly, 
specify a rate close to 0°.

• Horizontal and Vertical (Wrinkle tool only) 
Specifies how far apart the control points are placed.

• Brush Affects Anchor Points, Brush Affects In 
Tangent Handles, and Brush Affects Out Tangent 
Handles (Scallop, Crystallize, Wrinkle tools) 
Enables the tool brush to make changes to these 
properties.

Figure 30 Drag to distort

Figure 31 Result of Bloat tool distortion

Figure 32 Bloat Tool options dialog box
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About the Blend tool

You can blend objects to create and distribute shapes evenly between two objects (Figure 33). You can also blend 
between two open paths to create a smooth transition between objects, or you can combine blends of colors and 
objects to create color transitions in the shape of a particular object (Figure 34). Blending objects is not the same as 
applying blending modes or transparency to objects. 

Figure 33 Example of using a blend to distribute shapes evenly between two objects 

Figure 34 Example of using a blend to distribute color smoothly between two objects 

Once you create a blend, the blended objects are treated as one object. If you move one of the original objects or edit 
the original object’s anchor points, the blend changes accordingly. In addition, the new objects blended between the 
original objects don’t have their own anchor points. You can expand the blend in order to divide the blend into 
distinct objects.

The following rules apply to blended objects and their associated colors:

• You cannot blend between mesh objects.

• If you blend between one object painted with a process color and another object painted with a spot color, 
the blended shapes are painted with a blended process color. If you blend between two different spot colors, 
process colors are used to paint the intermediate steps. If, however, you blend between tints of the same spot 
color, the steps are all painted with percentages of the spot color.

• If you blend between two patterned objects, the blended steps will only use the fill of the object on the 
topmost layer.

• If you blend between objects that have blending modes specified with the Transparency panel, the blended 
steps will only use the blending mode of the top object.

• If you blend between objects with multiple appearance attributes (effects, fills, or strokes), Illustrator 
attempts to blend the options.

• If you blend between two instances of the same symbol, blended steps will be instances of that symbol. If, 
however, you blend between two instances of different symbols, the blended steps will not be symbol 
instances.
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• By default, blends are created as knockout transparency groups, so if any of the steps consist of overlapping 
transparent objects, these objects will not show through each other. You can change this setting by selecting 
the blend and deselecting Knockout Group in the Transparency panel.

The Blend tool and Make Blend command let you create blends, which are a series of intermediate objects and colors 
between two or more selected objects.

How to create a blend with the Blend tool:

1. Select the Blend tool (Figure 35).

2. Do one of the following:

• To blend in sequential order with no rotation, click 
anywhere on each object, but avoid anchor points 
(Figure 36).

• To blend to a specific anchor point on an object, 
click the anchor point with the Blend tool. When the 
pointer is over an anchor point, the pointer changes 
from a white square to transparent with a black dot in 
its center.

• To blend open paths, select an endpoint on each path.

3. When you are finished adding objects to the blend, click 
the Blend tool again.

Figure 35 Tools panel

Figure 36 Click in the center object to blend with 
an object below

Applying effects

Illustrator includes a variety of effects, which you can apply to an object, group, or layer to change its characteristics.

Once you apply an effect to an object, the effect appears in the Appearance panel (Figure 37). From the Appearance 
panel, you can edit the effect, move it, duplicate it, delete it, or save it as part of a graphic style. When you use an 
effect, you must expand the object before you can access the new points.

Figure 37 Appearance panel

Blend tool

Drop Shadow effect
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The effects in the top half of the Effects menu are vector effects (Figure 38). You can apply these effects only to 
vector objects or to the fill or stroke of a bitmap object in the Appearance panel. The following effects and effects 
categories from the top section are exceptions to this rule and can be applied to both vector and bitmap objects: 3D 
effects, SVG Filters, Warp effects, Transform effects, Drop Shadow, Feather, Inner Glow, and Outer Glow.

The effects in the bottom half of the Effects menu are raster effects. You can apply them to either vector or bitmap 
objects. 

How to apply a drop shadow effect:

1. Select the object or group (or target a layer in the Layers 
panel).

If you want to apply an effect to a specific attribute of an 
object, such as its fill or stroke, select the object and then 
select the attribute in the Appearance panel.

2. Choose Effect > Stylize > Drop Shadow from the Effect 
menu (Figure 38).

The Drop Shadow dialog box opens (Figure 39)

3. Set drop shadow options, and then click OK.

The drop shadow effect is applied (Figure 40).

Figure 38 Effect menu

Figure 39 Drop Shadow dialog box

Figure 40 Drop shadow effect applied
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