
Adobe Photoshop Guide
How to use selection tools
When using Adobe Photoshop, you will frequently need to select only parts of an image. Then you can make changes 
only to those parts. You can also cut and paste a selection to a new background. Practice using the selection tools. 
They can be tricky, but learning them is well worth the effort. The better you are at using them, the more flexibility 
you have with changing parts of images.

This guide covers the basics of using three different types of selection tools:

• Quick Selection and Magic Wand tools: Select parts of an image that have similar colors.

• Marquee tools: Select a geometrically shaped area, such as a rectangle or circle.

• Lasso tools: Define a selection area by hand.

After you make your selection, you can place the selection on a new layer mask. You can use masks to hide portions 
of a layer and reveal portions of the layers below. Two types of masks are available: layer and vector. Layer masks are 
resolution-dependent bitmap images you can edit with the painting or selection tools in our list. Vector masks are 
resolution independent; you can create them with a pen or shape tool. This guide looks at creating a vector mask by 
using a shape tool.

About the Quick Selection and Magic Wand tools

You can use two similar yet related selection tools to select parts of an image: the Quick Selection tool and the Magic 
Wand tool (Figure 1).

You can use the Quick Selection tool to quickly “paint” a selection using an adjustable round brush tip. As you drag, 
the selection expands outward and automatically finds and follows defined edges in the image.

You can use the Magic Wand tool to select an area of consistent color (for example, a sky background) without 
having to trace its outline.You specify the color range, or tolerance, for the Magic Wand tool’s selection, based on 
similarity to the pixel color you click. 

Figure 1 Selection tools

To use the Magic Wand tool:

1. Click the Magic Wand tool in the Tools panel.

The pointer changes to a magic wand.
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Figure 2 Selection options

2. Specify one of the selection options in the options bar. 
The pointer changes, depending on which option you 
select (Figure 2).

3. In the options bar, specify any of the following options:

Tolerance determines the similarity or difference of the 
pixels selected. Enter a value in pixels, ranging from 0 to 
255. A low value selects the few colors very similar to 
the pixel you click. A higher value selects a broader 
range of colors.

Anti-aliased creates a smooth-edged selection.

Contiguous selects only adjacent areas that use the same 
colors. Otherwise, all pixels in the entire image that use 
the same colors are selected.

In the example illustrated in Figure 2, the Add To button 
is selected, the Sample Size is set to Point Sample, the 
tolerance is set to 32, and the Anti-alias and Contiguous 
options are selected.

4. In the image, click the color you want to select 
(Figure 3).

Figure 3 illustrates what happens when the background 
of the butterfly image is clicked with the settings shown 
in Figure 2.

Note: After your initial click, the pointer changes to a 
magic wand with a plus (+) symbol. This indicates that 
more clicks will add to the selected area. Continue 
clicking until you have selected the entire area.

5. After you select the entire area, you can make changes to 
it, such as creating a Color Balance adjustment layer to 
alter the sky background color (choose Window > 
Adjustments, and then click the Color Balance button) 
(Figure 4).

Figure 3 Using the Magic Wand tool

Figure 4 Color Balance Adjustment layer applied to 
selection
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Using the marquee tools

The marquee tools enable you to select rectangles, ellipses, and 1-pixel rows and columns (Figure 5).

• Rectangular Marquee: Makes a rectangular selection (or a square, when used with the Shift key).

• Elliptical Marquee: Makes an elliptical selection (or a circle, when used with the Shift key).

• Single Row or Single Column Marquee: Defines the border as a 1-pixel-wide row or column.

Figure 5 Marquee tools with Rectangular Marquee tool selected

To use the Rectangular Marquee tool:

1. Click the Rectangular Marquee tool in the Tools panel.

The pointer changes to a cross.

2. Drag the pointer across the area you wish to select 
(Figure 6).

3. When you have completed your selection, release the 
mouse.

The area remains selected.

Note: To adjust the location of the selection slightly, 
press the arrow keys.

Any changes you make now apply only to the selection. 
For example, you can alter the lightness of the selected 
area (choose Window > Adjustments, and then click the 
Brightness/Contrast button) by adjusting the sliders 
(Figure 7). 

Figure 6 Rectangular selection

Figure 7 Photo Filter applied to selection
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Smoothing the edges of selections

Often you can improve results by softening the edges of selections, especially if you plan to copy them to a new 
background. You can use two options to smooth edges: feathering and anti-aliasing. Both options are available 
through the options bar when you choose selection tools (Figure 8).

Figure 8 Elliptical Marquee tool options bar 

• Anti-aliasing smoothes the edges of a selection by softening the color transition between edge pixels and 
background pixels. Because only the edge pixels change, no detail is lost. The effect of anti-aliasing is slight, 
but it can be effective in many situations. You can apply anti-aliasing to selections made by the Lasso tool, 
the Polygonal Lasso tool, the Magnetic Lasso tool, the Elliptical Marquee tool, and the Magic Wand tool. 
(Note: You must select anti-aliasing before using the tool. After you make a selection, you cannot add anti-
aliasing.)

• Feathering blurs a selection’s edges by adding a transition boundary between the selection and its 
surrounding pixels. You can set the width of this boundary in the options bar. In many cases, a boundary of 
3–5 pixels is sufficient. (This blurring can cause some loss of detail at the edge of the selection.) The effect 
of feathering is more dramatic than anti-aliasing, but you may prefer the results when you move objects to a 
markedly different background. You can define feathering for the Lasso tool, the Polygonal Lasso tool, the 
Magnetic Lasso tool, and the marquee tools as you use each tool, or you can add feathering to an existing 
selection. (Note: You will not see the effects of feathering until you move, cut, copy, or fill the selection.)

The Refine Edge option improves the quality of selection edges, letting you view the selection against different 
backgrounds for easy editing. Click the Refine Edge button in the options bar to access the advanced options 
(Figure 9). 

Figure 9 Refine Edge dialog box 

View Mode Menu

Refine Radius and Erase 
Refinements tools
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The options available from the Refine Edge dialog box include:

• View Mode: From the pop-up menu, choose a mode to change how the selection is displayed. Show Original 
displays the image without a selection preview. Show Radius displays the selection border where edge 
refinement occurs.

• Refine Radius and Erase Refinements tools: Let you precisely adjust the border area in which edge 
refinement occurs. 

• Smart Radius: Automatically adjusts the radius for hard and soft edges found in the border region.

• Radius: Determines the size of the selection border in which edge refinement occurs. Increase the radius to 
create a more exact selection boundary in areas with soft transitions or fine detail. The ideal radius depends 
upon selection size and content, so experiment with different settings.

• Smooth: Reduces irregular areas (“hills and valleys”) in the selection border to create a smoother outline.

• Feather: Create a soft-edged transition. 

• Contrast: Sharpen selection edges and remove fuzziness. Typically, however, the Smart Radius option and 
refinement tools are more effective.

• Shift Edge: Shrink or enlarge the selection boundary. Enter a positive value to expand or a negative value to 
contract. Most useful for making subtle adjustments to soft-edged selections. Shrinking the selection can 
help remove unwanted background colors from selection edges.

• Decontaminate Colors: Replaces color fringes with the color of the subject. 

Note: Because this option changes pixel color, it requires output to a new layer or document, preventing 
unexpected changes to the current layer.

• Amount: Changes the level of decontamination and fringe replacement.

• Output To: Determines whether the refined selection becomes a selection or mask on the current layer, or 
produces a new layer or document.

Using the lasso tools

Photoshop has three lasso tools, so named because you can enclose a selection in a flexible shape—just like a rope.

• Lasso selection tool: Useful for drawing freeform segments of a selection border. The most difficult 
selection tool to use but the most precise.

• Polygonal Lasso tool: Slightly easier to use, enabling you to select areas by using straight lines and selection 
points.

• Magnetic Lasso tool: Automatically snaps to the borders of defined areas in the image. Best used with 
objects that contrast sharply with their background.

This guide explains how to use the Polygonal Lasso tool. Using the Lasso tool is similar, but the selection is entirely 
freehand. Experiment with all three lassos after you are comfortable with the Polygonal Lasso.
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To use the Polygonal Lasso tool to create a cutout image on a new background:

1. Click and hold the Lasso in the Tools panel, and select 
the Polygonal Lasso tool from the menu (Figure 10).

The pointer changes to a polygon.

Note: Once you select the Polygonal Lasso, it appears by 
default in the menu until you select a different lasso tool.

2. In the options bar, make sure Add To Selection is 
selected and set Feather to 3 px (Figure 11).

When you increase Feather slightly, you ensure that the 
edges of the selection will be soft and the object will 
blend well into a new background.

3. Click the border of the object you wish to select.

It may help to increase the object’s magnification.

4. Next, move the pointer a short distance away along the 
object’s border and click again.

As you do so, you form a connected segment with 
endpoints.

5. Continue creating small segments until you enclose the 
entire object. 

When you move the pointer over your original starting 
point, a closed circle appears next to the Polygon lasso 
pointer (Figure 12).

6. Click to close the selection. 

7. Click the Refine Edge button in the options bar.

The Refine Edge dialog box opens (Figure 9).

8. Select a View Mode option (Figure 13) so that the edges 
of the selection are easy to isolate against the 
background. 

For example, a dark background will be more useful for 
defining the edges of the lighthouse illustrated in the 
example.

Note: For information about each mode, hover the 
pointer over it until a tool tip appears. Press F to cycle 
through the View Mode options, or press X to 
temporarily disable all views.

Figure 10 Lasso tools in the Tools panel

Figure 11 Polygonal Lasso options

Figure 12 Click to create selection segments until 
the loop is closed

Figure 13 View Mode options

Add To Selection Set Feather

Closed circle

View Mode 
pop-up menu
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9. In the Edge Detection area, select the Smart Radius 
option.

10. Adjust the Radius slider to change the size of the 
refinement area and soften the edges of the border region.

Observe the results of the edge refinement (Figure 14).

Occasionally you may have to fine-tune an edge selection 
beyond using the Smart Radius. To do this, use the 
Refine Radius tool.

11. Click the Refine Radius and Erase Refinements tools 
button and select the Refine Radius tool (Figure 15).

The pointer changes to a circle brush with cross hair.

12. Drag along the edge to refine the edge selection 
(Figure 16).

Observe the results of the edge refinement (Figure 17). 

Note: To change the brush size, press the bracket keys, or 
use the Size slider in the Control panel .

13. In the Output area, select the Decontaminate Colors 
option and set the Output To option to New Layer With 
Layer Mask.

14. Click OK.

The selection is placed on its own masked layer 
(Figure 18).

15. Click on the square beside the original layer (the 
background layer) to activate the eyeball icon and make 
the layer visible. 

16. If the image layer is the background layer, double-click 
the image layer in the Layers panel to convert it from a 
background layer into a regular layer.

17. Click OK in the New Layer dialog box.

18. Click the Background layer itself to select it.

19. Choose Select > All.

20. Press Delete to remove the original background.

21. With the background layer still selected, click the Paint 
Bucket tool.

22. Click the Set Foreground button in the Tools panel and 
choose a color to lay down behind the selection. 

Figure 14 Edge radius adjustment, before and after

Figure 15 Refine Radius and Erase Refinements 
Tools

Figure 16 Refine Radius tool

Figure 17 Refine Radius Tool results

Figure 18 New layer with layer mask
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23. Click in the background layer to add a new background 
color (Figure 19).

Observe that the object’s layers blend into the 
background. This is because of the refined radius you 
added to the selection.

Figure 19 Object with a new background

About vector mask layers

In the previous section, you used a polygonal lasso to select an area of an image so you could paste it into a new layer. 
You can also use a vector mask to create a cutout image. A vector mask creates a sharp-edged shape on a layer and is 
useful any time you want to add a design element with clean, defined edges. After you create a layer with a vector 
mask, you can apply one or more layer styles to it.

Vector masks are resolution independent and are created with a pen or shape tool. Vector masks are nondestructive, 
which means you can re-edit the masks later without losing the pixels they hide. In the Layers panel, a vector mask 
appears as an additional thumbnail to the right of the layer thumbnail. The vector mask thumbnail represents a path 
that clips out the contents of the layer.

The Properties panel with Masks (Figure 20) provides controls to adjust a mask. You can change the opacity of a 
mask to let more or less of the content show, invert the mask, or refine the mask borders, as with a selection area.

Figure 20 Properties panel 

Properties panel button

Mask density
Layer mask button

Vector mask button

Feather mask

Apply mask Disable/Enable mask Delete mask

Panel menu
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To create a vector mask layer:

1. Open the image file to which you want to add a vector 
mask layer.

2. Click the Layers tab to bring the Layers panel to the front 
or, if the panel isn’t visible, choose Window > Layers.

3. If the image layer is the background layer, double-click 
the image layer in the Layers panel to convert it from a 
background layer into a regular layer (Figure 21). If the 
image is already a regular layer, skip ahead to step 5.

Note: Because background layers are locked, you can’t 
move them in the Layers panel. You need to convert 
background layers to regular layers to unlock them.

The New Layer dialog box appears (Figure 22).

4. In the New Layer dialog box, you can rename the layer. 
Click OK to close the dialog box and convert the image 
layer from a background to a regular layer.

5. Confirm the new layer is selected in the Layers panel and 
choose Layer > Vector Mask > Hide All.

The layer contents disappear due to the new vector mask 
that hides the entire layer.

6. Click the Properties panel button to open the Masks 
options (Figure 20). 

7. Select one of the shape tools, such as the Ellipse tool 
(Figure 24).

The pointer appears as a cross hair.

8. Click the vector mask thumbnail in the Layers panel to 
highlight it.

9. Select the Path option from the Tool Mode menu in the 
Shape option bar and select the Combine Shapes option 
in the Path Operations menu (Figure 24).

Note:

10. Shift-drag the shape tool to draw one or more shapes over 
the image.

The vector mask creates sharp-edged shapes on a layer 
that reveals the parts of the image within the shapes 
(Figure 25).

Figure 21 Layers panel

Figure 22 New Layer dialog box

Figure 23 Shape tools in the Tools panel

Figure 24 Shape option bar

Figure 25 Parts of the image revealed through 
combined shapes of vector mask

Tool Mode menu Path Operations menu
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11. Drag the Density slider in the Properties panel to adjust 
the mask opacity.

At 100% density, the mask is completely opaque and 
blocks out any underlying area of the layer. As you lower 
the density, more of the area under the mask becomes 
visible. In the example (Figure 26), the mask density is 
set to 30% so that the area under the mask is partially 
visible.

12. To create a background layer with a solid fill color, click 
the Layers panel menu (Figure 27) and choose New 
Layer.

The New Layer dialog box appears.

13. Click OK to close the New Layer dialog box and create a 
new layer.

14. In the Layers panel, drag the new layer below the vector 
mask layer and confirm that the new layer is selected.

15. Choose Edit > Fill.

The Fill dialog box appears (Figure 28).

16. In the Fill dialog box, choose one of the following 
options for Use, or select a custom pattern:

Foreground Color, Background Color, Black, 50% Gray, 
or White: Fills the selection with the specified color.

Color: Fills with a color you select from the Color Picker.

Pattern: Fills the selection with a pattern. Click the 
inverted arrow next to the pattern sample, and select a 
pattern from the pop-up palette. You can load additional 
patterns by using the pop-up panel menu. Select the name 
of a library of patterns, or choose Load Patterns and 
navigate to the folder containing the patterns you want to 
use.

History: Restores the selected area to a state or snapshot 
of the image set as the source in the History panel. 

Note: If you fill a CMYK image by using the Black 
option, Photoshop fills all the channels with 100% black. 
This may result in more ink than is allowable by the 
printer. For best results when filling a CMYK image, use 
the Foreground option with the foreground color set to an 
appropriate black.

17. Specify the blending mode and opacity for the paint.

18. Select the Preserve Transparency option.

Figure 26 Adjusting the mask density

Figure 27 Layers panel

Figure 28 Fill dialog box

Panel menu
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19. Click OK to apply the fill.

20. (Optional) To crop the image, select the Crop tool from 
the Tools panel.

21. Drag over the part of the image you want to keep to 
create a marquee. The marquee doesn’t have to be 
precise—you can adjust the cropping marquee as needed.

22. To complete the crop (Figure 29), press Enter (Windows) 
or Return (Mac OS).

Figure 29 Completed image crop
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